summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-05-20 02:10:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-20 02:19:18 +0200
commit183524070bdd4330eabb2262adee1fd0d912b4c3 (patch)
treead12a6eabf9542056e615df25dbf3a054c2f626b /sys-apps
parentapp-shells/dash: Bump to v0.5.10.2 (diff)
downloadgentoo-183524070bdd4330eabb2262adee1fd0d912b4c3.tar.gz
gentoo-183524070bdd4330eabb2262adee1fd0d912b4c3.tar.bz2
gentoo-183524070bdd4330eabb2262adee1fd0d912b4c3.zip
sys-apps/debianutils: Bump to v4.8.6
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/debianutils/Manifest1
-rw-r--r--sys-apps/debianutils/debianutils-4.8.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/debianutils/Manifest b/sys-apps/debianutils/Manifest
index 25ede174cbf4..f97d3f941b24 100644
--- a/sys-apps/debianutils/Manifest
+++ b/sys-apps/debianutils/Manifest
@@ -1,3 +1,4 @@
DIST debianutils_4.7.tar.xz 156276 BLAKE2B 9d32dc8222b67d4f1f91d58af0811412924f5de43a691463bc24ac51087f986440d6464fee71f7723980b9c21c579cd4aef70213d5033c419f3802be3bd4cd29 SHA512 74110d194de8b6b61d40b133b97629520048a8fdedac349ec2031c793c0246526c1c7904e88098b4c2a121e5efba2d724924139ab1aca15d129a4d210f94a1aa
DIST debianutils_4.8.3.tar.xz 159292 BLAKE2B e655741f42594ff12b4f349331da57ec09073802c9778594619686c93fc3061cf5248ac8e9e2c1b391eb49dd572f3033b1db206ff43f373b17caf7f3c835111f SHA512 468b8f001c0338f166cbc2fe25079edc5feeaa38dce2f5c7e6724c691d6cb35f4843e987695e33ead557bb11887e78ff8a5e3e1f52a266a0f32fb978fa643897
DIST debianutils_4.8.4.tar.xz 156344 BLAKE2B 069d15039579d4ce03d2ca4bfd0df199f0044049e7cd6ca899104eec5d917f3db290649bfdd851d8b14519df2750fb975bc6d96e98e14cdb626a610d44da80b0 SHA512 7d7b2d12d4907f6032477b4cd5b5dc94d8093724af8a97859c1d4cf229479e2dfe6d44143b454ed9b1990ca2d4833eaeb059659d8c305623875fdc8420659855
+DIST debianutils_4.8.6.tar.xz 156532 BLAKE2B 2add390a0e38aa3d7103e09b3b65fa2b88c3965ca411c5789409454519791bccdb12d89b1bea4d07417f733d23d0662d4f510750ab404d7a4e8f20c2bd3d7ef4 SHA512 5913729cc3c56962e8939b71803258952df0d7204df8090a7504fbefc7f5d1da8e749d606fe23148ea3294909ef172bc1f4f821690169e861729caab70921a2f
diff --git a/sys-apps/debianutils/debianutils-4.8.6.ebuild b/sys-apps/debianutils/debianutils-4.8.6.ebuild
new file mode 100644
index 000000000000..f454a8bd5fda
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-4.8.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+installkernel static"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
+
+src_configure() {
+ use static && append-ldflags -static
+ default
+}
+
+src_install() {
+ into /
+ dobin tempfile run-parts
+ if use installkernel ; then
+ dosbin installkernel
+ fi
+
+ into /usr
+ dosbin savelog
+
+ doman tempfile.1 run-parts.8 savelog.8
+ use installkernel && doman installkernel.8
+ cd debian || die
+ dodoc changelog control
+ keepdir /etc/kernel/postinst.d
+}