summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-06-03 09:31:08 -0400
committerKenton Groombridge <concord@gentoo.org>2022-06-03 21:03:16 -0400
commit1d61df2c8f1219aaf12922d7b866636a78352475 (patch)
treef999111c8f48ac4b9a00349dad11c77dec8200b1 /sys-apps
parentsys-apps/semodule-utils: bump to 3.4 (diff)
downloadgentoo-1d61df2c8f1219aaf12922d7b866636a78352475.tar.gz
gentoo-1d61df2c8f1219aaf12922d7b866636a78352475.tar.bz2
gentoo-1d61df2c8f1219aaf12922d7b866636a78352475.zip
sys-apps/mcstrans: bump to 3.4
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mcstrans/Manifest1
-rw-r--r--sys-apps/mcstrans/mcstrans-3.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/mcstrans/Manifest b/sys-apps/mcstrans/Manifest
index b150878307f9..1ee16b6a9d7d 100644
--- a/sys-apps/mcstrans/Manifest
+++ b/sys-apps/mcstrans/Manifest
@@ -1,2 +1,3 @@
DIST mcstrans-3.3.tar.gz 44621 BLAKE2B 624780c219d0b8f369def5ab334caf9d2ae847f9cfb4359ce38e240bcb72b7cfeef45d08cd6e7330cc90394f6c32bd622d2133e675036f98992145b1530ab1e2 SHA512 2157a0361bb5a2bc8e149373b2dd7d9b042f8c4c0aa845ae6967a23d9b875d2dcd6176d99d7f8f15e17eb5877fea60814e19aabfe76950d25b75c9c25df811c2
DIST mcstrans-3.4-rc1.tar.gz 45128 BLAKE2B 90ef74de6db72005b17254a23673edca30c8441155947b0cd11e5a45b376a58f608eca38fc91184e33dd593551de48010bde1962849ad7d6427d310c4e2609e4 SHA512 7889b6b4a22d2b3b900b28fddfb09d32bcc8d4dfacb3ac75253aa812b35578907272b758c4050d52560cdb751cefca5f4bd46c8c2402b47f8833c63134b8e780
+DIST mcstrans-3.4.tar.gz 45125 BLAKE2B 59a403e7d4018bee2632360d5720e65f26b0581ed58a42e8caee2d352d104658e27ece850ca6c50ea513766a973c6ae98fd4115d478555dd5c130956188c0668 SHA512 bd612f1ae886c7a0300bb4aa1d52f139677787cc026475eada98e11a46910fa4a8baba9026530af6fa649a4f07978039f584e55567b87bbbb89ff06fb182518c
diff --git a/sys-apps/mcstrans/mcstrans-3.4.ebuild b/sys-apps/mcstrans/mcstrans-3.4.ebuild
new file mode 100644
index 000000000000..75563498db4f
--- /dev/null
+++ b/sys-apps/mcstrans/mcstrans-3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre2:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/mcstransd.init" mcstransd
+}