summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-17 11:43:13 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-17 11:43:29 -0700
commit2497e491a50e04a66aaad39cc483fb33b7a40af0 (patch)
tree0f63b207c719a6413d11894042a78ad1bcc23923 /sys-apps
parentmail-client/evolution: Fix CVE-2020-11879 (diff)
downloadgentoo-2497e491a50e04a66aaad39cc483fb33b7a40af0.tar.gz
gentoo-2497e491a50e04a66aaad39cc483fb33b7a40af0.tar.bz2
gentoo-2497e491a50e04a66aaad39cc483fb33b7a40af0.zip
sys-apps/linux-misc-apps: QA cleanups
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild
index 45c7b3fd3bb5..86827070d512 100644
--- a/sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild
+++ b/sys-apps/linux-misc-apps/linux-misc-apps-5.6.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-inherit versionator eutils toolchain-funcs linux-info ltprune autotools flag-o-matic
+inherit versionator eutils toolchain-funcs linux-info autotools flag-o-matic
DESCRIPTION="Misc tools bundled with kernel sources"
HOMEPAGE="https://kernel.org/"
@@ -191,14 +191,19 @@ src_install() {
newdoc README README.usbip
newdoc AUTHORS AUTHORS.usbip
popd >/dev/null
- dodoc Documentation/usb/usbip_protocol.txt
+ dodoc Documentation/usb/usbip_protocol.rst
+ find "${D}" -name 'libusbip*.la' -delete || die
fi
- mv -f "${D}"/usr/sbin/{,iio_}generic_buffer
+ # At one point upstream it was moved, but be generic to detect if it's
+ # happened already
+ if [[ -f "${D}"/usr/sbin/generic_buffer ]] && \
+ [[ ! -f "${D}"/usr/sbin/iio_generic_buffer ]]; then
+ mv -f "${D}"/usr/sbin/{,iio_}generic_buffer || die
+ fi
newconfd "${FILESDIR}"/freefall.confd freefall
newinitd "${FILESDIR}"/freefall.initd freefall
- prune_libtool_files
}
pkg_postinst() {
@@ -206,7 +211,7 @@ pkg_postinst() {
elog "The cpupower utility is maintained separately at sys-power/cpupower"
elog "The lguest utility no longer builds, and has been dropped."
elog "The hpfall tool has been renamed by upstream to freefall; update your config if needed"
- if find /etc/runlevels/ -name hpfall ; then
+ if find "${ROOT}"/etc/runlevels/ -name hpfall ; then
ewarn "You must change hpfall to freefall in your runlevels!"
fi
if use usbip; then