summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-08-12 22:53:34 -0400
committerMike Gilbert <floppym@gentoo.org>2020-08-12 22:54:37 -0400
commit36555159f4904788d3f95cddff14058056607fd9 (patch)
tree68bb6cabe491e81d089a6fd1dd1204f623966f34 /sys-apps
parentdev-perl/Mojolicious: Bump to version 8.570.0 (diff)
downloadgentoo-36555159f4904788d3f95cddff14058056607fd9.tar.gz
gentoo-36555159f4904788d3f95cddff14058056607fd9.tar.bz2
gentoo-36555159f4904788d3f95cddff14058056607fd9.zip
sys-apps/hwids: bump to 20200813
Closes: https://bugs.gentoo.org/736746 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/Manifest1
-rw-r--r--sys-apps/hwids/hwids-20200813.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/sys-apps/hwids/Manifest b/sys-apps/hwids/Manifest
index ccf1a31f162a..22a8bc232fd8 100644
--- a/sys-apps/hwids/Manifest
+++ b/sys-apps/hwids/Manifest
@@ -3,3 +3,4 @@ DIST hwids-20190818.tar.gz 3407208 BLAKE2B c2a0098cba4a34210461a2781f325a95f1869
DIST hwids-20191025.tar.gz 3443988 BLAKE2B 0352f1568d7ceeb2c599d789f96a3175703f3c86240188beb9a080eabb6e7659aeeadf193f15050519fb64c58ee8d8832919cf6922b5017861b32be543235a03 SHA512 6f637ca8c4d6b1261c5c2eccd8d1a64ab750f4c36f3d435b50b75949c15e571d83bc61dd6a14e777b53d383d7d02c34f616cc6a62d005db3d965b33b4121deca
DIST hwids-20200204.tar.gz 3495191 BLAKE2B 23075b6728d9b0e020be45729d0df4cef95cac5e912e646b612266337d1add59c87a1031e6672c5b6eb23e13c26e6299b62a5886aa25017242a86fd474c1e9ae SHA512 1d2a9baaa7ab64575a3d9b98ae4df9060cb8593ae752365296dd53b18bc5996170bbfe1c5b4b1ffc24b28e3dbaa7c321c4fa333bbf91449a6ca7b187cbe23741
DIST hwids-20200306.tar.gz 3512152 BLAKE2B 6a6ee48598e72f97a90bff8f45aacb699218570ede5b60ed119ebae78de6cd4b92e02f96cf57c83710da699be9a7dcdfdef8d404539e04b664298874b35e54ce SHA512 eff1d2783925ca459b387fbaa5cf68a98aa4209ab8509ad92a902b4d02cc7f4a47e5506c2beed4c792d24a8ab636ad77b376a92b59ae4f605d1b5258350ff250
+DIST hwids-20200813.tar.gz 3775577 BLAKE2B 7421b39318c7e3476d066441a4e079a0934ce5338a564fd40e39d73b7739eebf1a668f16d3a53a0eac692d07687f9135aefe81934b27d8eec95c67c06f6649d1 SHA512 096070205381fc8b698276d8927d71831684129921c1165323b62ac624a5694f779dd601b25db6dc28a01878704c3de9ff37dbb2696867afafea527544cff2e4
diff --git a/sys-apps/hwids/hwids-20200813.ebuild b/sys-apps/hwids/hwids-20200813.ebuild
new file mode 100644
index 000000000000..bbe6c639f9b4
--- /dev/null
+++ b/sys-apps/hwids/hwids-20200813.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2012-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+if [[ ${PV} == 99999999 ]]; then
+ PYTHON_COMPAT=( python3_{6,7} )
+ inherit git-r3 python-any-r1
+ EGIT_REPO_URI="https://github.com/gentoo/hwids.git"
+else
+ SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+IUSE="+net +pci +udev +usb"
+
+RDEPEND="
+ udev? ( virtual/udev )
+ !<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1
+"
+
+if [[ ${PV} == 99999999 ]]; then
+ BDEPEND="
+ net-misc/curl
+ udev? ( $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]') )
+ "
+ python_check_deps() {
+ if use udev; then
+ has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
+ fi
+ }
+else
+ S=${WORKDIR}/hwids-${P}
+fi
+
+pkg_setup() {
+ :
+}
+
+src_unpack() {
+ if [[ ${PV} == 99999999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ emake fetch
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e '/udevadm hwdb/d' Makefile || die
+}
+
+_emake() {
+ emake \
+ NET=$(usex net) \
+ PCI=$(usex pci) \
+ UDEV=$(usex udev) \
+ USB=$(usex usb) \
+ "$@"
+}
+
+src_compile() {
+ if [[ ${PV} == 99999999 ]] && use udev; then
+ python_setup
+ _emake udev-hwdb
+ fi
+ _emake
+}
+
+src_install() {
+ _emake install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ if use udev; then
+ udevadm hwdb --update --root="${ROOT}"
+ fi
+}