summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-22 23:48:52 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-22 23:49:06 +0100
commit3a9ab2090d0838dbae5516153859e8a6ec62c84c (patch)
tree36a89c79e49ff72407dc2a6c9e8074e74a328c5b /sys-apps
parentx11-plugins/wmhdplop: 0.9.11 bump (diff)
downloadgentoo-3a9ab2090d0838dbae5516153859e8a6ec62c84c.tar.gz
gentoo-3a9ab2090d0838dbae5516153859e8a6ec62c84c.tar.bz2
gentoo-3a9ab2090d0838dbae5516153859e8a6ec62c84c.zip
sys-apps/grep: fix automagic dependency on dev-libs/libsigsegv
Closes: https://bugs.gentoo.org/673524 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/grep/grep-3.0-r1.ebuild (renamed from sys-apps/grep/grep-3.0.ebuild)4
-rw-r--r--sys-apps/grep/grep-3.1-r1.ebuild (renamed from sys-apps/grep/grep-3.1.ebuild)2
-rw-r--r--sys-apps/grep/grep-3.3-r1.ebuild (renamed from sys-apps/grep/grep-3.3.ebuild)2
3 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/grep/grep-3.0.ebuild b/sys-apps/grep/grep-3.0-r1.ebuild
index 69114f07cfa0..90ba1b045513 100644
--- a/sys-apps/grep/grep-3.0.ebuild
+++ b/sys-apps/grep/grep-3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -34,6 +34,8 @@ src_prepare() {
src_configure() {
use static && append-ldflags -static
+ # don't link against libsigsegv even when available
+ export ac_cv_libsigsegv=no
# Always use pkg-config to get lib info for pcre.
export ac_cv_search_pcre_compile=$(
usex pcre "$($(tc-getPKG_CONFIG) --libs $(usex static --static '') libpcre)" ''
diff --git a/sys-apps/grep/grep-3.1.ebuild b/sys-apps/grep/grep-3.1-r1.ebuild
index 05ec1d0402d6..bc8dc4beb4fb 100644
--- a/sys-apps/grep/grep-3.1.ebuild
+++ b/sys-apps/grep/grep-3.1-r1.ebuild
@@ -35,6 +35,8 @@ src_prepare() {
src_configure() {
use static && append-ldflags -static
+ # don't link against libsigsegv even when available
+ export ac_cv_libsigsegv=no
# Always use pkg-config to get lib info for pcre.
export ac_cv_search_pcre_compile=$(
usex pcre "$($(tc-getPKG_CONFIG) --libs $(usex static --static '') libpcre)" ''
diff --git a/sys-apps/grep/grep-3.3.ebuild b/sys-apps/grep/grep-3.3-r1.ebuild
index 93d0d7122038..635945feb366 100644
--- a/sys-apps/grep/grep-3.3.ebuild
+++ b/sys-apps/grep/grep-3.3-r1.ebuild
@@ -37,6 +37,8 @@ src_prepare() {
src_configure() {
use static && append-ldflags -static
+ # don't link against libsigsegv even when available
+ export ac_cv_libsigsegv=no
# Always use pkg-config to get lib info for pcre.
export ac_cv_search_pcre_compile=$(
usex pcre "$($(tc-getPKG_CONFIG) --libs $(usex static --static '') libpcre)" ''