summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-10-02 18:52:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-07 23:06:41 +0200
commit3f9649777c14a331b3f29c0bc77f223656eec5a0 (patch)
treedf78a3b2efd383aac6d6ca09b915af048664eaae /sys-apps
parentdev-libs/qtkeychain: Remove 0.8.0 (diff)
downloadgentoo-3f9649777c14a331b3f29c0bc77f223656eec5a0.tar.gz
gentoo-3f9649777c14a331b3f29c0bc77f223656eec5a0.tar.bz2
gentoo-3f9649777c14a331b3f29c0bc77f223656eec5a0.zip
sys-apps/dstat: avoid running network... etc tests
This fixes the test target to only load a restricted number of the shipped plugins - network, db, virtualisation... etc will fail in different ways unless the environment or explicit dependencies are met. Closes: https://bugs.gentoo.org/638728 Closes: https://bugs.gentoo.org/656514 Signed-off-by: Paul Healy <lmiphay@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10046 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dstat/dstat-0.7.3.ebuild2
-rw-r--r--sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/sys-apps/dstat/dstat-0.7.3.ebuild b/sys-apps/dstat/dstat-0.7.3.ebuild
index cbdd1df1a54c..372d70a1fd0a 100644
--- a/sys-apps/dstat/dstat-0.7.3.ebuild
+++ b/sys-apps/dstat/dstat-0.7.3.ebuild
@@ -24,6 +24,8 @@ RDEPEND="
)"
DEPEND=""
+PATCHES=( "${FILESDIR}/dstat-${PV}-skip-non-sandbox-tests.patch" )
+
src_install() {
emake DESTDIR="${ED}" install
einstalldocs
diff --git a/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch b/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch
new file mode 100644
index 000000000000..48eb542ed195
--- /dev/null
+++ b/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch
@@ -0,0 +1,15 @@
+--- a/Makefile 2016-03-18 13:03:22.000000000 +0000
++++ b/Makefile 2018-10-02 11:11:00.344942941 +0100
+@@ -32,9 +32,11 @@
+ rm -f examples/*.pyc plugins/*.pyc
+ $(MAKE) -C docs clean
+
++TEST_PLUGINS=--cpufreq --disk-avgqu --disk-avgrq --disk-svctm --disk-tps --disk-util --disk-wait --dstat-cpu --dstat-ctxt --dstat-mem --dstat --helloworld --md-status --net-packets --proc-count --snooze --test --top-bio-adv --top-bio --top-childwait --top-cpu-adv --top-cpu --top-cputime-avg --top-cputime --top-int --top-io-adv --top-io --top-latency-avg --top-latency --top-mem --top-oom
++
+ test:
+ ./dstat -taf 1 5
+- ./dstat -t --all-plugins 1 5
++ ./dstat -t $(TEST_PLUGINS) 1 5
+
+ dist: clean
+ $(MAKE) -C docs dist