summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2022-03-09 18:50:10 +0100
committerJonas Stein <jstein@gentoo.org>2022-03-09 18:50:10 +0100
commit43488a42b43b78e5cda834b3d61848fc7cc6b6bf (patch)
tree8a1e56c3667742faeaa5122d8076edc75cd46df1 /sys-apps
parentwww-client/firefox: stabilize 91.7.0 for amd64 (diff)
downloadgentoo-43488a42b43b78e5cda834b3d61848fc7cc6b6bf.tar.gz
gentoo-43488a42b43b78e5cda834b3d61848fc7cc6b6bf.tar.bz2
gentoo-43488a42b43b78e5cda834b3d61848fc7cc6b6bf.zip
sys-apps/inxi: Bump to 3.3.13
Version bump to 3.3.13 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.13.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index a156f4836b3c..bf99acc8f283 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -3,3 +3,4 @@ DIST inxi-3.3.04.1.tar.gz 450695 BLAKE2B 3bf2fc9296c9b1e2357e7df2edeb3df5069d48b
DIST inxi-3.3.06.1.tar.gz 460416 BLAKE2B a7a5eeade861294c8c18cd9594ef6fd0c681d8ae66b6e1b112dbc968be46a617db666d863f5138883d7651fad8e3b27c4f27a2b518233ffa2aae7e453feab62b SHA512 0e9d7215339235914cfcd7292443199304d44e528545a0c1c3d65d597f57da5c2678c410d215e6c8668c22677f20d62c93bbd7fee02dc74f8c9aab75b1488d00
DIST inxi-3.3.08.1.tar.gz 467132 BLAKE2B c0254174c0a48936e1f183c16f985838cf74302da706996c1baec0c67b9c4209da5b555805cb668d626eccaa69f95e3cab2605b06d2cc7361a6cd3ff5d88c29e SHA512 bcbb81dd022dbd525ed3811406997c6689f968de8a3b6e0988381d9d2a488617ef3bc966034f9baac8eebb412b8d2e612b7cece29d65bdcb20d8b8cdeca112e6
DIST inxi-3.3.12.1.tar.gz 495524 BLAKE2B 76b8600ea5bb5430a30bf3876ca80c1dbc8033449c3526c945d7457f3d9176d6299acf6d1a0b3e92c2f84e4b01ba70acbb326cfc9cd5b906e9e5a28550efa670 SHA512 5772b77a35342b6dee7211f31a35552794fddcdb01012e604c501707f1e3756791376b92e5c8f3d8c85493b83f2394d2e6f90f6e473225388975de2e174a2997
+DIST inxi-3.3.13.1.tar.gz 524354 BLAKE2B de12d2145f61b385d636aa9aa1efa057cfa12b010789ec34602ee7567d4db34a960a85b47d17f7a4db8cdb68a44d1085ca2f3be11ca503e5172525d75901d244 SHA512 6eed08ed0efb3574d294127beaec1373df434554ad98debd25ac865b85ab98e81e11f0cee855da0213cbc25fee95ce8504c7eaee90d99b8ad7c63f2b301394f3
diff --git a/sys-apps/inxi/inxi-3.3.13.1.ebuild b/sys-apps/inxi/inxi-3.3.13.1.ebuild
new file mode 100644
index 000000000000..27490346a682
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}