summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-09-15 21:49:08 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-09-15 21:49:08 +0100
commit528ec5ed42c888999ebaef931c716d6c01122d9c (patch)
tree80b7b404cf4da1d3fc5a7c418c8685a788d1bf2b /sys-apps
parentsys-libs/binutils-libs: stable 2.28.1 for alpha/amd64/arm/hppa/ia64/ppc/ppc64... (diff)
downloadgentoo-528ec5ed42c888999ebaef931c716d6c01122d9c.tar.gz
gentoo-528ec5ed42c888999ebaef931c716d6c01122d9c.tar.bz2
gentoo-528ec5ed42c888999ebaef931c716d6c01122d9c.zip
sys-apps/nix: bump up to 1.11.15
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/nix/Manifest1
-rw-r--r--sys-apps/nix/nix-1.11.15.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/sys-apps/nix/Manifest b/sys-apps/nix/Manifest
index 3f4fb2cbe9dd..8aa06e86e334 100644
--- a/sys-apps/nix/Manifest
+++ b/sys-apps/nix/Manifest
@@ -2,3 +2,4 @@ DIST nix-1.11.11.tar.xz 625248 SHA256 f5b9da21fb412e4c35b6e2bc771cfbf4ca44746be5
DIST nix-1.11.12.tar.xz 631940 SHA256 02e8d85cfc02494fb04c90d8443dfea433639b9f787989b18f54567fd9769dd2 SHA512 fc2a06841cfa70c2d0b69315b0b8e30530e1b982e8a6b72e8f41c84db4efe7fc89738dce97f356f47d28518860990870fd54eb688704c531ba08231d2a3dd012 WHIRLPOOL b99e213e68cd479f9b6f8104e5f328c9bc409883aa1a88c155acf3f0a49ee95981f1774eff0d803b21182c0a087434a2910a9631dcaa97aae1847697473b27ea
DIST nix-1.11.13.tar.xz 632224 SHA256 0913975e262f8069fde6e71a5fae757bb3aef558c51d1711034c525146ea5913 SHA512 7244b49a7c7416e6ecc7754abcf48028d650510ac27f26701ccc3954660e26ad8b083fdc4ae07de718d3df49ca2a6af3bf3261d537e962a90233f87b13cd1606 WHIRLPOOL a4af739a21e6080fccdfc885c24833e08765fae450fc7833484843f97fee7a4087619f67328075026b55efeda01a9cbf6bf80eb9918bdbbcee96414ee28d363c
DIST nix-1.11.14.tar.xz 632260 SHA256 26593c831addf1d40f6b7d131f394cb0f9fbec9e46471369faed16eaa2c4b7e4 SHA512 48ed17a090a161ad35c8e84652566e527f31586184b8722a5536a6d83eee1e81911b6c4d5f0661f57054db6c47b5d8211f2acf47899fbec72f2c4bf8a5262af5 WHIRLPOOL d6db1f452dd5bb430a0e02644af89a3e648f3f0f898b81b60ef4d7b8c8d7c9498c0992c3c33637eafd3ff1d23f55df3b76e1a1da957a0b7066a88e3eff1c35ef
+DIST nix-1.11.15.tar.xz 632544 SHA256 d20f20e45d519f54fae5c61d55eadcf53e6d7cdbde9870eeec80d499f9805165 SHA512 449b3c78b74c776215dfbe9d6d09b96d8c6abf996c69c525073df12d0cffb1a2868890d356fbb52c794e2c6f485018756395625e7b170166f7c6f9e2bdd364d9 WHIRLPOOL 740cdd89aa4d10af8e80329a52299c7333a5820ca4b943c4527b8342c60edf07e9bfaad3378546903e052a66155f974df36ee74f6119926714c5b12d9455f2f4
diff --git a/sys-apps/nix/nix-1.11.15.ebuild b/sys-apps/nix/nix-1.11.15.ebuild
new file mode 100644
index 000000000000..d4e616516f72
--- /dev/null
+++ b/sys-apps/nix/nix-1.11.15.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic readme.gentoo-r1 user
+
+DESCRIPTION="A purely functional package manager"
+HOMEPAGE="https://nixos.org/nix"
+
+SRC_URI="http://nixos.org/releases/${PN}/${P}/${P}.tar.xz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+etc_profile +gc doc sodium"
+
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ dev-db/sqlite
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-libs/libseccomp
+ sys-libs/zlib
+ gc? ( dev-libs/boehm-gc[cxx] )
+ doc? ( dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )
+ sodium? ( dev-libs/libsodium )
+ dev-lang/perl:=
+ dev-perl/DBD-SQLite
+ dev-perl/WWW-Curl
+ dev-perl/DBI
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-2.6
+ >=sys-devel/flex-2.5.35
+ virtual/perl-ExtUtils-ParseXS
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.11.6-systemd.patch
+ "${FILESDIR}"/${PN}-1.11.6-per-user.patch
+ "${FILESDIR}"/${PN}-1.11.6-respect-CXXFLAGS.patch
+ "${FILESDIR}"/${PN}-1.11.6-respect-LDFLAGS.patch
+)
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS=" Quick start user guide on Gentoo:
+
+[as root] enable nix-daemon service:
+ [systemd] # systemctl enable nix-daemon
+ [openrc] # rc-update add nix-daemon
+[as a user] relogin to get environment and profile update
+[as a user] fetch nixpkgs update:
+ \$ nix-channel --update
+[as a user] install nix packages:
+ \$ nix-env -i mc
+[as a user] configure environment:
+ Somewhere in .bash_profile you might want to set
+ LOCALE_ARCHIVE=\$HOME/.nix-profile/lib/locale/locale-archive
+ but please read https://github.com/NixOS/nixpkgs/issues/21820
+
+Next steps:
+ nix package manager user manual: http://nixos.org/nix/manual/
+"
+
+pkg_setup() {
+ enewgroup nixbld
+ for i in {1..10}; do
+ # we list 'nixbld' twice to
+ # both assign a primary group for user
+ # and add a user to /etc/group
+ enewuser nixbld${i} -1 -1 /var/empty nixbld,nixbld
+ done
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/nix/var \
+ $(use_enable gc)
+}
+
+src_compile() {
+ local make_vars=(
+ OPTIMIZE=0 # disable hardcoded -O3
+ V=1 # verbose build
+ )
+ emake "${make_vars[@]}"
+}
+
+src_install() {
+ # TODO: emacs highlighter
+ default
+
+ readme.gentoo_create_doc
+
+ # here we use an eager variant of something that
+ # is lazily done by nix-daemon and root nix-env
+
+ # TODO: will need a tweak for prefix
+ keepdir /nix/store
+ fowners root:nixbld /nix/store
+ fperms 1775 /nix/store
+
+ keepdir /nix/var/nix/profiles/per-user
+ fperms 1777 /nix/var/nix/profiles/per-user
+
+ # setup directories nix-daemon: /etc/profile.d/nix-daemon.sh
+ keepdir /nix/var/nix/gcroots/per-user
+ fperms 1777 /nix/var/nix/gcroots/per-user
+
+ newinitd "${FILESDIR}"/nix-daemon.initd nix-daemon
+
+ if ! use etc_profile; then
+ rm "${ED}"/etc/profile.d/nix.sh || die
+ rm "${ED}"/etc/profile.d/nix-daemon.sh || die
+ fi
+}
+
+pkg_postinst() {
+ if ! use etc_profile; then
+ ewarn "${EROOT}etc/profile.d/nix.sh was removed (due to USE=-etc_profile)."
+ fi
+
+ readme.gentoo_print_elog
+}