summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-03-08 15:44:03 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-11 10:31:02 +0200
commit53e72ab7f94503aed9495efb11f7451f9ed36b66 (patch)
treed82f6545fdf5a60031a4093271e4a200269dbf51 /sys-apps
parentdev-lang/execline: add 2.8.3.0 (diff)
downloadgentoo-53e72ab7f94503aed9495efb11f7451f9ed36b66.tar.gz
gentoo-53e72ab7f94503aed9495efb11f7451f9ed36b66.tar.bz2
gentoo-53e72ab7f94503aed9495efb11f7451f9ed36b66.zip
sys-apps/s6: add 2.11.1.0
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/s6-2.11.1.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index 99c190f6d9a3..5b79e7e1b39e 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -1,2 +1,3 @@
DIST s6-2.11.0.1.tar.gz 227802 BLAKE2B 76721fdbc4fdbcb11d20eff31b817e66c49a488290ac8564a0418c5cd2ba3a204625dac2ce0dedcc8fccb18f54c5178253627f6874160b748db323cb4a34f32e SHA512 e833ae42d7094a46eea4d914c8e9b07b030cab2c6010c1d7698a070d14adbb62a614822a9575a3064a6b8a5a856146fc9fa27661f0d84569dac14ad6cdbf84d9
+DIST s6-2.11.1.0.tar.gz 228745 BLAKE2B 872ac1f736337a8e6617c46af92f8e894c06a4b40501ebf58568dc6a58cb594fdf36654cdb8cfd8e922431c17f9b4f82441296a3ce8031ba8b1f27fa1ba8a051 SHA512 ab3cb4a61fae21537eacffdaa427a0a6b23b12088586f0cd8dc993e0de29e9863d04c8706cb044acdc08254002b19eb5f894262d37348d467f8c713d8124e738
DIST s6-2.9.2.0.tar.gz 205009 BLAKE2B a3b3299d7d8695b4c3555a9603763e51c7c8d84d05ea229c787e46af8f5dca3efc09d16eb3380fbbd8e9ff1d300eddb5f632082ffa8dfbe08d45b5799f705131 SHA512 ef814c0426d00112c793d4f8bb99319cde8e4ab91c24e98401559bbd28eafdb11a66d446a31816a50f67d607ed1e8c55383362e9761abca21ca24b3598929eee
diff --git a/sys-apps/s6/s6-2.11.1.0.ebuild b/sys-apps/s6/s6-2.11.1.0.ebuild
new file mode 100644
index 000000000000..bf45c253220e
--- /dev/null
+++ b/sys-apps/s6/s6-2.11.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+execline static static-libs"
+
+REQUIRED_USE="static? ( static-libs )"
+
+RDEPEND="execline? ( >=dev-lang/execline-2.8.3.0:=[static-libs?] )
+ >=dev-libs/skalibs-2.11.2.0:=[static-libs?]
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/execline
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ $(usex execline '' '--disable-execline' )
+ --enable-shared
+ $(use_enable static allstatic)
+ $(use_enable static static-libc)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}