summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-05-03 09:53:54 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-05-03 10:14:40 +0100
commit5942fca28577976e174abda2dc86445206590fd0 (patch)
tree229737b093e647b6c1aac199fb003875413f5d94 /sys-apps
parentdev-scheme/guile-git: bump up to release 0.2.0 version (diff)
downloadgentoo-5942fca28577976e174abda2dc86445206590fd0.tar.gz
gentoo-5942fca28577976e174abda2dc86445206590fd0.tar.bz2
gentoo-5942fca28577976e174abda2dc86445206590fd0.zip
sys-apps/guix: bump up to 1.0.0
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/guix/Manifest1
-rw-r--r--sys-apps/guix/guix-1.0.0.ebuild152
2 files changed, 153 insertions, 0 deletions
diff --git a/sys-apps/guix/Manifest b/sys-apps/guix/Manifest
index 88c1ca8fc612..28dc1b1ce3a4 100644
--- a/sys-apps/guix/Manifest
+++ b/sys-apps/guix/Manifest
@@ -1,5 +1,6 @@
DIST guix-0.15.0.tar.gz 22704560 BLAKE2B 6abd50c0436abedaa3a20ba9649ccf8af0efeeac8d975171befb4e9a231be99bfcebed34f08d66b4ddaedfd64a9916f176e96bf810dba3bbc13cc6856828b5be SHA512 5e85ed03cde979d625df11d02d4f2ac7128bd944d11a763754e10a8e980f1eaeb721053fa12547bbc4289b33b3c7818bf992c7bfe79233f3a9555c96b8d52d7f
DIST guix-0.16.0.tar.gz 24365691 BLAKE2B 7581f21fc9ccd4813b5e35b6a56980ffcd1ef9b02d5091679c33aaa91edf80acdc2bb9bd1a73acdde71b74d88e990ebbd824267756d9e7b27f94061cfd5a1429 SHA512 fdfa431547a283947147fde67e0dab27361a34caf7862c10659b17f74c63a07e6e834281be48a3dbe05cccd8ef46db5b8a19a6d42668ae2258d696058283724f
+DIST guix-1.0.0.tar.gz 30707058 BLAKE2B 061aaa7068b2da641a613c36838d9853eeefd6ab6a2d9d9645a86fbeb9a7dcd370cc6a0d2ff45469235c2296edde540471675ed858522dcd6351e853a8617ff8 SHA512 45af6f80d1d4f4a63d00741070904acbb4986241561f52b4e81ce92fcdab6806a9ee10cbabfb6eddf88c4132cf9d678640d3a2c9895f170f8e6cbbf4d2128419
DIST guix-bootstrap-aarch64-linux-20170217-guile-2.0.14.tar.xz.bootstrap 2948976 BLAKE2B 3337e52c2db259af98a6ed0eb418a6cd388e11e09c277c460e14edb7065d0170fd544415ccb72db1b1b2559fe700ce313698aed11846271052460f9af51f499a SHA512 b3a5b457017357dedb71db98ef089ac90ca2b88ec5dbf0cec6c829dff7167c5478797a8d14850dd2d951713632c2859950be6c5eb029e6f6c224eecef97efd27
DIST guix-bootstrap-armhf-linux-20150101-guile-2.0.11.tar.xz.bootstrap 2717576 BLAKE2B b7461803f0b3943ef1c855b02f4eef55ef96479cd453fb7ee11518159deca65f741d9c3384598a2fdb0b05b7a9023fb6983a5a3a6ccc204b0c6ac1328f3203cc SHA512 d546e2c0f676a49af482caae6f5575c7937647a81d37e49ad8be6fe12d58989cb825b5e12f2da28aff4649ee1a198ffb8f4a0beea65835a60aefaa905e87e337
DIST guix-bootstrap-i686-linux-20131110-guile-2.0.9.tar.xz.bootstrap 2656076 BLAKE2B a2c0c82ac3ba4ff5265a506bbe644dc6a61a38cec243e34e8d3bde2d543a4d7221aa921f57f057eb5379aea4e9fd462f0bee7df7e61e4e6381c93401948a9b11 SHA512 f2b257e5b10dcd7421273d8d04782a2bd733781094dd963bf5bd8294604dbd158ea25cbc383a227edce84de968a962ec834226ebdd137a2e1857e2191bfada8c
diff --git a/sys-apps/guix/guix-1.0.0.ebuild b/sys-apps/guix/guix-1.0.0.ebuild
new file mode 100644
index 000000000000..218eb8858e5d
--- /dev/null
+++ b/sys-apps/guix/guix-1.0.0.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools readme.gentoo-r1 user
+
+DESCRIPTION="GNU package manager (nix sibling)"
+HOMEPAGE="https://www.gnu.org/software/guix/"
+
+# taken from gnu/local.mk and gnu/packages/bootstrap.scm
+BOOT_GUILE=(
+ "aarch64-linux 20170217 guile-2.0.14.tar.xz"
+ "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ "i686-linux 20131110 guile-2.0.9.tar.xz"
+ "mips64el-linux 20131110 guile-2.0.9.tar.xz"
+ "x86_64-linux 20131110 guile-2.0.9.tar.xz"
+)
+
+binary_src_uris() {
+ local system_date_guilep uri
+ for system_date_guilep in "${BOOT_GUILE[@]}"; do
+ # $1 $2 $3
+ # "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ set -- ${system_date_guilep}
+ uri="mirror://gnu-alpha/${PN}/bootstrap/$1/$2/$3"
+ # ${uri} -> guix-bootstrap-armhf-linux-20150101-guile-2.0.11.tar.xz.bootstrap
+ echo "${uri} -> guix-bootstrap-$1-$2-$3.bootstrap"
+ done
+}
+
+# copy bootstrap binaries from DISTDIR to ${S}
+copy_boot_guile_binaries() {
+ local system_date_guilep
+ for system_date_guilep in "${BOOT_GUILE[@]}"; do
+ # $1 $2 $3
+ # "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ set -- ${system_date_guilep}
+ cp "${DISTDIR}"/guix-bootstrap-$1-$2-$3.bootstrap gnu/packages/bootstrap/$1/$3 || die
+ done
+}
+
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ $(binary_src_uris)"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # complains about size of config.log and refuses to start tests
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-scheme/guile-2.2:=[regex,networking,threads]
+ dev-scheme/bytestructures
+ dev-scheme/guile-gcrypt
+ >=dev-scheme/guile-git-0.2.0
+ dev-scheme/guile-json
+ dev-scheme/guile-sqlite3
+ net-libs/gnutls[guile]
+ sys-libs/zlib
+ app-arch/bzip2
+ dev-db/sqlite
+"
+
+DEPEND="${RDEPEND}
+"
+
+PATCHES=("${FILESDIR}"/${PN}-0.16.0-default-daemon.patch)
+
+QA_PREBUILT="usr/share/guile/site/*/gnu/packages/bootstrap/*"
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS="Quick start user guide on Gentoo:
+
+[as root] allow binary substitution to be downloaded (optional)
+ # guix archive --authorize < /usr/share/guix/ci.guix.info.pub
+[as root] enable guix-daemon service:
+ [systemd] # systemctl enable guix-daemon
+ [openrc] # rc-update add guix-daemon
+[as a user] ln -sf /var/guix/profiles/per-user/\$USER/guix-profile \$HOME/.guix-profile
+[as a user] install guix packages:
+ \$ guix package -i hello
+[as a user] configure environment:
+ Somewhere in .bash_profile you might want to set
+ export GUIX_LOCPATH=\$HOME/.guix-profile/lib/locale
+
+Next steps:
+ guix package manager user manual: https://www.gnu.org/software/guix/manual/guix.html
+"
+
+pkg_setup() {
+ enewgroup guixbuild
+ for i in {1..10}; do
+ # we list 'guixbuild' twice to
+ # both assign a primary group for user
+ # and add a user to /etc/group
+ enewuser guixbuilder${i} -1 -1 /var/empty guixbuild,guixbuild
+ done
+}
+
+src_prepare() {
+ copy_boot_guile_binaries
+
+ default
+ # build system is very eager to run automake itself: bug #625166
+ eautoreconf
+
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/guix/modules.go
+ # is newer than
+ # guix/modules.scm
+ # In case it is instead of using 'guix/modules.scm' guile
+ # loads system one (from potentially older version of guix).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_configure() {
+ # to be compatible with guix from /gnu/store
+ econf \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ # guile occasionally fails with 'bad address'
+ emake -j1
+}
+
+src_install() {
+ # TODO: emacs highlighter
+ default
+
+ readme.gentoo_create_doc
+
+ keepdir /etc/guix
+ # TODO: will need a tweak for prefix
+ keepdir /gnu/store
+ fowners root:guixbuild /gnu/store
+ fperms 1775 /gnu/store
+
+ keepdir /var/guix/profiles/per-user
+ fperms 1777 /var/guix/profiles/per-user
+
+ newinitd "${FILESDIR}"/guix-daemon.initd guix-daemon
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}