summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-08 15:08:24 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-08 15:40:29 -0800
commit623e1a6218b9c0f57617e21795a271499ed466c8 (patch)
tree30f2c272575d50c2a09eb770064c633f6b4081ec /sys-apps
parentapp-shells/mcfly: drop old (diff)
downloadgentoo-623e1a6218b9c0f57617e21795a271499ed466c8.tar.gz
gentoo-623e1a6218b9c0f57617e21795a271499ed466c8.tar.bz2
gentoo-623e1a6218b9c0f57617e21795a271499ed466c8.zip
sys-apps/ripgrep: switch to cargo.eclass func args
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild b/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
index f5c384a3c895..f7eda9ddd13b 100644
--- a/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
+++ b/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -116,25 +116,16 @@ src_test() {
}
src_compile() {
- export CARGO_HOME="${ECARGO_HOME}"
- cargo build -j $(makeopts_jobs) \
- $(usex debug "" --release) \
- $(usex pcre "--features pcre2" "") \
- || die "cargo build failed"
+ cargo_src_compile $(usex pcre "--features pcre2" "")
}
src_install() {
- cargo install -j $(makeopts_jobs) --root="${D}/usr" \
- $(usex debug --debug "") \
- $(usex pcre "--features pcre2" "") \
- || die "cargo install failed"
-
- rm -f "${D}/usr/.crates.toml" || die
+ cargo_src_install $(usex pcre "--features pcre2" "")
# hack to find/install generated files
# stamp file can be present in multiple dirs if we build additional features
# so grab fist match only
- local BUILD_DIR=$(dirname $(find target/release -name ripgrep-stamp -print -quit))
+ local BUILD_DIR="$(dirname $(find target/release -name ripgrep-stamp -print -quit))"
if use man ; then
doman "${BUILD_DIR}"/rg.1