summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-27 17:03:07 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-27 17:03:59 -0500
commit663c5cf752b24425fa93c8f9a0fbf22077314520 (patch)
treedda0fa8c759b64f9161a7ba026ccd819003a8682 /sys-apps
parentmedia-gfx/gscan2pdf: extraneous use of eutils. (diff)
downloadgentoo-663c5cf752b24425fa93c8f9a0fbf22077314520.tar.gz
gentoo-663c5cf752b24425fa93c8f9a0fbf22077314520.tar.bz2
gentoo-663c5cf752b24425fa93c8f9a0fbf22077314520.zip
sys-apps/systemd: add kernel check for CGROUP_BPF
Closes: https://bugs.gentoo.org/638860 Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/systemd-235-r1.ebuild1
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-235-r1.ebuild b/sys-apps/systemd/systemd-235-r1.ebuild
index e31cdbf14872..a83897f709fe 100644
--- a/sys-apps/systemd/systemd-235-r1.ebuild
+++ b/sys-apps/systemd/systemd-235-r1.ebuild
@@ -118,6 +118,7 @@ pkg_pretend() {
use seccomp && CONFIG_CHECK+=" ~SECCOMP ~SECCOMP_FILTER"
kernel_is -lt 3 7 && CONFIG_CHECK+=" ~HOTPLUG"
kernel_is -lt 4 7 && CONFIG_CHECK+=" ~DEVPTS_MULTIPLE_INSTANCES"
+ kernel_is -ge 4 10 && CONFIG_CHECK+=" ~CGROUP_BPF"
if linux_config_exists; then
local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 032a4e3441e3..e32db7f21900 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -116,6 +116,7 @@ pkg_pretend() {
use seccomp && CONFIG_CHECK+=" ~SECCOMP ~SECCOMP_FILTER"
kernel_is -lt 3 7 && CONFIG_CHECK+=" ~HOTPLUG"
kernel_is -lt 4 7 && CONFIG_CHECK+=" ~DEVPTS_MULTIPLE_INSTANCES"
+ kernel_is -ge 4 10 && CONFIG_CHECK+=" ~CGROUP_BPF"
if linux_config_exists; then
local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)