summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-08-25 17:18:45 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-01 00:12:37 +0200
commit839982df603c11f36430decfdafdab032094f0e9 (patch)
treecf29dd9ac650a8a008196c112300412f3ac8c4c9 /sys-apps
parentapp-admin/syslog-ng: drop old. (diff)
downloadgentoo-839982df603c11f36430decfdafdab032094f0e9.tar.gz
gentoo-839982df603c11f36430decfdafdab032094f0e9.tar.bz2
gentoo-839982df603c11f36430decfdafdab032094f0e9.zip
sys-apps/smc-sum: update fetch instructions.
Bug: https://bugs.gentoo.org/663666 Package-Manager: Portage-2.3.48, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9696
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smc-sum/smc-sum-2.0.1.20180420-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/smc-sum/smc-sum-2.0.1.20180420-r1.ebuild b/sys-apps/smc-sum/smc-sum-2.0.1.20180420-r1.ebuild
new file mode 100644
index 000000000000..423244a7d81e
--- /dev/null
+++ b/sys-apps/smc-sum/smc-sum-2.0.1.20180420-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN/smc-/}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Updates the BIOS and IPMI firmware and system settings on Supermicro mainboards"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_Linux_x86_64_${MY_DATE}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RDEPEND="sys-apps/smc-sum-driver"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_Linux_x86_64"
+
+DOCS=( "ReleaseNote.txt" "SUM_UserGuide.pdf" "ExternalData/SMCIPID.txt" "ExternalData/VENID.txt" )
+
+QA_PREBUILT="usr/bin/smc-sum"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SUM"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ newbin sum smc-sum
+
+ einstalldocs
+}