summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-18 11:13:50 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-18 11:13:50 +0100
commit9459e79a96970d383c534aac07d00aaaa67a238f (patch)
tree425f8352135caa58f2c0a525d01a5dc5733f9145 /sys-apps
parentx11-plugins/vicious: take over following maksbotan's disappearance (diff)
downloadgentoo-9459e79a96970d383c534aac07d00aaaa67a238f.tar.gz
gentoo-9459e79a96970d383c534aac07d00aaaa67a238f.tar.bz2
gentoo-9459e79a96970d383c534aac07d00aaaa67a238f.zip
sys-apps/ucspi-ssl: Fix build with gcc-10
Closes: https://bugs.gentoo.org/707156 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ucspi-ssl/files/ucspi-ssl-0.99e-fno-common.patch56
-rw-r--r--sys-apps/ucspi-ssl/ucspi-ssl-0.99e.ebuild10
2 files changed, 62 insertions, 4 deletions
diff --git a/sys-apps/ucspi-ssl/files/ucspi-ssl-0.99e-fno-common.patch b/sys-apps/ucspi-ssl/files/ucspi-ssl-0.99e-fno-common.patch
new file mode 100644
index 000000000000..ea7aa0a47688
--- /dev/null
+++ b/sys-apps/ucspi-ssl/files/ucspi-ssl-0.99e-fno-common.patch
@@ -0,0 +1,56 @@
+https://bugs.gentoo.org/707156
+--- a/src/ip6_bit.c
++++ b/src/ip6_bit.c
+@@ -7,7 +7,7 @@
+
+ #define BITSUBSTITUTION
+
+-char strnum[FMT_ULONG];
++extern char strnum[FMT_ULONG];
+
+ /**
+ * This function converts a IPv6 address into its binary representation.
+--- a/src/remoteinfo.c
++++ b/src/remoteinfo.c
+@@ -50,7 +50,7 @@ static int doit(stralloc *out,int s,char ipremote[4],uint16 portremote,char iplo
+ {
+ buffer b;
+ char bspace[128];
+- char strnum[FMT_ULONG];
++ extern char strnum[FMT_ULONG];
+ int numcolons;
+ char ch;
+
+--- a/src/sslclient.c
++++ b/src/sslclient.c
+@@ -98,7 +98,7 @@ static stralloc moreaddresses;
+
+ static stralloc tmp;
+ static stralloc fqdn;
+-char strnum[FMT_ULONG];
++extern char strnum[FMT_ULONG];
+ char ipstr[IP6_FMT];
+
+ char seed[128];
+--- a/src/sslhandle.c
++++ b/src/sslhandle.c
+@@ -91,7 +91,7 @@ static stralloc remotehostsa;
+ char *remotehost = 0;
+ char *verifyhost = 0;
+
+-char strnum[FMT_ULONG];
++extern char strnum[FMT_ULONG];
+ char strnum2[FMT_ULONG];
+
+ static stralloc tmp;
+--- a/src/sslserver.c
++++ b/src/sslserver.c
+@@ -87,7 +87,7 @@ char *verifyhost = 0;
+ unsigned long uid = 0;
+ unsigned long gid = 0;
+
+-char strnum[FMT_ULONG];
++extern char strnum[FMT_ULONG];
+ char strnum2[FMT_ULONG];
+
+ static stralloc tmp;
diff --git a/sys-apps/ucspi-ssl/ucspi-ssl-0.99e.ebuild b/sys-apps/ucspi-ssl/ucspi-ssl-0.99e.ebuild
index 2b8ea0ee5f83..03a26b48ecbf 100644
--- a/sys-apps/ucspi-ssl/ucspi-ssl-0.99e.ebuild
+++ b/sys-apps/ucspi-ssl/ucspi-ssl-0.99e.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ppc ppc64 s390 sparc x86"
IUSE="bindist perl libressl"
-DEPEND="libressl? ( dev-libs/libressl:0= )
+DEPEND="
+ libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0=[bindist=] )
perl? ( dev-lang/perl:= )"
RDEPEND="${DEPEND}
@@ -22,6 +23,8 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/host/superscript.com/net/${P}
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_prepare() {
ht_fix_all
@@ -41,8 +44,7 @@ src_prepare() {
if use bindist; then
echo > conf-ecdh || die
fi
-
- eapply_user
+ default
}
src_compile() {