summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-26 11:18:52 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-26 11:19:04 +0200
commit9be727961766f916a8f4a71236ec465095329fd3 (patch)
treebe18afc5fd55209dd0134999c7e502475018b478 /sys-apps
parentdev-libs/nettle: ia64 stable, bug #626010 (diff)
downloadgentoo-9be727961766f916a8f4a71236ec465095329fd3.tar.gz
gentoo-9be727961766f916a8f4a71236ec465095329fd3.tar.bz2
gentoo-9be727961766f916a8f4a71236ec465095329fd3.zip
sys-apps/tuned: EAPI 6 bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/tuned/tuned-2.7.1-r3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/tuned/tuned-2.7.1-r3.ebuild b/sys-apps/tuned/tuned-2.7.1-r3.ebuild
new file mode 100644
index 000000000000..d8d3a5fb28ad
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.7.1-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 systemd
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://fedorahosted.org/tuned/"
+SRC_URI="https://fedorahosted.org/releases/t/u/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${CDEPEND}"
+
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/dbus
+ sys-apps/ethtool
+ sys-power/powertop
+ sys-process/procps
+ dev-util/systemtap"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sysctl.patch"
+ "${FILESDIR}/${P}-makefile-rpm.patch"
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ Makefile || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ python_fix_shebang "${ED}"
+}