summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-30 11:07:52 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-30 11:07:52 +0200
commita5e4ed2858912fff28fce843be50cd87543a00e1 (patch)
treeb7ef293653f3ad03da72792c6773984608094c29 /sys-apps
parentdev-lang/ispc: use HTTPS for GitHub (diff)
downloadgentoo-a5e4ed2858912fff28fce843be50cd87543a00e1.tar.gz
gentoo-a5e4ed2858912fff28fce843be50cd87543a00e1.tar.bz2
gentoo-a5e4ed2858912fff28fce843be50cd87543a00e1.zip
sys-apps/pv: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/Manifest1
-rw-r--r--sys-apps/pv/pv-1.6.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index 870c01da6bfe..ad16300cf0d7 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1 +1,2 @@
DIST pv-1.6.0.tar.bz2 107723 SHA256 0ece824e0da27b384d11d1de371f20cafac465e038041adab57fcf4b5036ef8d SHA512 bd405901812ca50b910adbcf1d2c540dc0b8612f03687866734a79cfa5b5b8100024c18a1d1413c6613e1f2085989cbb77907da89bec7eda37cdeaa7597129d5 WHIRLPOOL 51312339fa1815a61f58fa0f49b0538289d0308b17c5d03c4c6a7e371052e9911d09cb7a9c1eb032b797a3f56eaa7e5dbfecaf6fb2c1faf3fd1b34c298782c1f
+DIST pv-1.6.6.tar.bz2 109220 SHA256 608ef935f7a377e1439c181c4fc188d247da10d51a19ef79bcdee5043b0973f1 SHA512 cc841b4bd00e4e8fcaed97da094ebac4a11af1c3f843ce5f73d0c3ab20aca29498c6b1a224c653d40127304d8269d96f413df66b980809e9278ff9544c834a26 WHIRLPOOL 0afb22c8fb84ed632ddf0657d0d8e2e054a08c16b14cf314b62b76a1afe79911b2c7133dc5ae7567c398305c9dd64d9dd8b2c9f97f4027faeac6d2ec32dfaabb
diff --git a/sys-apps/pv/pv-1.6.6.ebuild b/sys-apps/pv/pv-1.6.6.ebuild
new file mode 100644
index 000000000000..b3b8222481a9
--- /dev/null
+++ b/sys-apps/pv/pv-1.6.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="http://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PV_LINGUAS=( de fr pl pt )
+IUSE+=" ${PV_LINGUAS[@]/#/linguas_}"
+
+DOCS=( README doc/NEWS doc/TODO )
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+}
+
+src_configure() {
+ tc-export AR
+ local lingua
+ for lingua in ${PV_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ fi
+ done
+ econf $(use_enable debug debugging) $(use_enable nls)
+}
+
+src_test() {
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+ default
+}