summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-10-04 12:26:03 -0700
committerZac Medico <zmedico@gentoo.org>2020-10-04 12:26:37 -0700
commitaf4caea23797164effbab440282842ac15db3eef (patch)
tree4d95ce862a194a24f08c07fbeb1c87077662a644 /sys-apps
parentdev-python/reno: bump to 3.2.0, add Python 3.9 support+tests (diff)
downloadgentoo-af4caea23797164effbab440282842ac15db3eef.tar.gz
gentoo-af4caea23797164effbab440282842ac15db3eef.tar.bz2
gentoo-af4caea23797164effbab440282842ac15db3eef.zip
sys-apps/yarn: Bump to version 1.22.10
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/yarn/Manifest1
-rw-r--r--sys-apps/yarn/yarn-1.22.10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/yarn/Manifest b/sys-apps/yarn/Manifest
index bd6c370bfed8..a431fea5a5a0 100644
--- a/sys-apps/yarn/Manifest
+++ b/sys-apps/yarn/Manifest
@@ -1,2 +1,3 @@
+DIST yarn-v1.22.10.tar.gz 1244965 BLAKE2B 6a9471a6905d89481665c099f00a985daacc8c7953327ee12b3d70f3f42dc304ceca01446281964d1af7a005ecae4a12ca55df637732e52821b4ecb9cdce6418 SHA512 d75dccd318f280abcbfd8d78b63546e11e7a8459c5dd737d0c8da2742cd5d7e3d7a5e668ce680234b0c09e71d128787777061d24c6e3ae4b6626086461e3ce25
DIST yarn-v1.22.4.tar.gz 1244785 BLAKE2B 1f1eeb829096eaf19a8fdb48b46fa736769d9d3c247759e434413665186e4cccb750024afa836dae8a0130fc472df3c01805d263d81346e1dd7509e1b106e88a SHA512 a1833b862fe52169bd6c2a033045a07df5bc6a23595c259e675fed1b2d035ab37abe6ce309720abb6636d68f03615054b6292dc0a70da31c8697fda228b50d18
DIST yarn-v1.22.5.tar.gz 1244837 BLAKE2B cf5054893c8937ceb6788c27f23005386449664b36dc31c6c0c3548438f1fdc5c5ec4b1b1642786c4d8732faf46ab58d2784d3768e12233f241b9b1c6f173734 SHA512 c33c040ed57eb05c04905b8996db31a34099f0c18dbf1818959c5592514abc99f1180592561ec5d3e760c084dbcf2dcdf3ebb4fe8918f082b6aa089cf10921bb
diff --git a/sys-apps/yarn/yarn-1.22.10.ebuild b/sys-apps/yarn/yarn-1.22.10.ebuild
new file mode 100644
index 000000000000..706453936e75
--- /dev/null
+++ b/sys-apps/yarn/yarn-1.22.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+ net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
+}
+
+src_install() {
+ local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
+ insinto "${install_dir}"
+ doins -r .
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarnpkg" "/usr/bin/yarnpkg"
+
+ while read -r -d '' path; do
+ read -r shebang < "${ED}${path}" || die
+ [[ "${shebang}" == \#\!* ]] || continue
+ fperms +x "${path}"
+ done < <(find "${ED}" -type f -printf '/%P\0' || die)
+}