summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-16 11:36:25 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-16 11:38:32 +0200
commitcf063984cc7b2efb34e61c56a15b53362e7e277d (patch)
tree721feefa9906f4a0c679075e2d05e2d7f620117c /sys-apps
parentpackage.mask: Update dev-util/scons-3.0.1-r2 mask (diff)
downloadgentoo-cf063984cc7b2efb34e61c56a15b53362e7e277d.tar.gz
gentoo-cf063984cc7b2efb34e61c56a15b53362e7e277d.tar.bz2
gentoo-cf063984cc7b2efb34e61c56a15b53362e7e277d.zip
sys-apps/less: Bump to version 531
Bug: https://bugs.gentoo.org/646884 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-531.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index 196d87fdae1c..f63ed7d3afff 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -1,3 +1,4 @@
DIST less-487.tar.gz 318488 BLAKE2B 294ce992da39488fe5b50edf80d70179a45a449f5bcf8b93d6735be9f57db708734984f3a58654773155148c96037e2c445dac63abed1bc4ce655a4e472eca08 SHA512 d31274fdada570fbc6706d7c52637d1accbd18ce947ec062e10b1624c251a8533c6638bc3a1d89d3c70a0c7b9c6d45740598bec9003f281d64c587b1f829125a
DIST less-529.tar.gz 339651 BLAKE2B 745146fd584c6144b4052d18bae07a2b4c7a719d36c556c69837f2018ef95efeea35acadcb9946bdde0272848d1bd8537c847e89591d980ceb2eda5a4c5963c4 SHA512 902e3ed86161c5a9eb3c08567b6b702371b5c88a85ef0b21beada223eaa47e0abf4d4d166a4a7a195caef67509fa683d07d0b6a40b529d703ee26aa8910c360a
DIST less-530.tar.gz 339723 BLAKE2B 9321548b06330c0b1b5b5a36147f5b9348619ff15d907808744b89581edeb4d8c2118ba455d024a23850902cac4d2c34d1e7b9897e02769584315c0e67ef667e SHA512 8d83a18b5648c4fe85921a563aa2c40bcf495aeb611098c83cd167b1e2f706649846cdf457c8506ae2683ab362ad970a0b261747349673020894bccdb9acbc10
+DIST less-531.tar.gz 340466 BLAKE2B 6ac75b623fce478114d18cff429659499fedf4ef1a7bb067465ace91c28a7968efb224a4994a1e376a8cf40b110492f10ecda634628029107b38187044a0cd1e SHA512 180b665f194d7cc40d4bbb37bd64b10be463c0705e81795bef84b20dbba1c61825bb3e3da8bcd79f9176bb3af7b1f4e4c3dfe0829a5a2195a11f5b42294daca1
diff --git a/sys-apps/less/less-531.ebuild b/sys-apps/less/less-531.ebuild
new file mode 100644
index 000000000000..6509cbbb85e3
--- /dev/null
+++ b/sys-apps/less/less-531.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}