summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-01-04 13:21:30 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-01-04 13:21:30 +0100
commitd215ce97c1b8c641dd25e29f23d1800c9b9df0d4 (patch)
tree2d31525a4a3bb2b210a3dcc0c866d948231d3430 /sys-apps
parentnet-libs/nodejs: Old. (diff)
downloadgentoo-d215ce97c1b8c641dd25e29f23d1800c9b9df0d4.tar.gz
gentoo-d215ce97c1b8c641dd25e29f23d1800c9b9df0d4.tar.bz2
gentoo-d215ce97c1b8c641dd25e29f23d1800c9b9df0d4.zip
sys-apps/yarn: Version bump to 1.3.2
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/yarn/Manifest1
-rw-r--r--sys-apps/yarn/yarn-1.3.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/yarn/Manifest b/sys-apps/yarn/Manifest
index 6da2e6d9c8fb..0ebda1f7eda6 100644
--- a/sys-apps/yarn/Manifest
+++ b/sys-apps/yarn/Manifest
@@ -1,2 +1,3 @@
DIST yarn-v1.1.0.tar.gz 874168 BLAKE2B 2c2e00237e4c1264ba3167f5fbeb40ef64d9ca42b05bd4e005673437c9c2ef084e93db00811840aa6cac6fbdec912cff654b09a81bbd6ccfb954d1e14128cd79 SHA512 7ce740ac47d8ba42c47d0262979fcd1d22daede2a298e1743341c52584bee7d4beca8758c118deccaefd9cb0bc2780a37e110ae3633af56ac6916ae0389eadf6
DIST yarn-v1.2.1.tar.gz 885691 BLAKE2B ba7a291e4b071cd285e890fbd8af2a1adf78bc7a65ddaf7adcebee2b8bc15d4b98293eeae79be5ad664daa6a56d553ade1fd5e50aaafc7ed2f980ebfe4feac58 SHA512 cb61788e16cd3537073b3a8711ce6a29f7e14380cea20ca16144e97ed05ec62c685b805a18af9e70d16f7aedb4c460cad97027e37fb43596f97570386d596477
+DIST yarn-v1.3.2.tar.gz 886500 BLAKE2B 224503241b646bd6befe6571022e1081c4e9cce2371ce0c111704a6f0ceb7c4b4f0267c9c37d05feec60311cc7804706fb47d130ca64e6182590e88d8476b386 SHA512 d488ae56b60884bb42e5e2ac8a0359c6947e234ed8b5bba12a93f24abb4419b4a6fef708c35df8caa9e68edca3fe570d1dcda9295d29438e45a32ef5d029aedf
diff --git a/sys-apps/yarn/yarn-1.3.2.ebuild b/sys-apps/yarn/yarn-1.3.2.ebuild
new file mode 100644
index 000000000000..bb76e804940f
--- /dev/null
+++ b/sys-apps/yarn/yarn-1.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/yarn-v${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+ net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ local install_dir="/usr/$(get_libdir)/node_modules/yarn" path
+ insinto "${install_dir}"
+ doins -r .
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+ fperms a+x "${install_dir}/bin/yarn.js"
+ while read -r -d '' path; do
+ [[ $(head -n1 "${path}") == \#\!* ]] || continue
+ chmod +x "${path}" || die #614094
+ done < <(find "${ED}" -type f -print0)
+}