summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 01:01:45 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:29 -0700
commitd2c403cb162f8b984cae2989e087ca5148b17751 (patch)
treee450052fea85cd0656b3562b9d3010f531f89ff6 /sys-apps
parentsys-apps/semodule-utils: Version updated to 3.2. (diff)
downloadgentoo-d2c403cb162f8b984cae2989e087ca5148b17751.tar.gz
gentoo-d2c403cb162f8b984cae2989e087ca5148b17751.tar.bz2
gentoo-d2c403cb162f8b984cae2989e087ca5148b17751.zip
sys-apps/semodule-utils: Sync live ebuild.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/semodule-utils/semodule-utils-9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sys-apps/semodule-utils/semodule-utils-9999.ebuild b/sys-apps/semodule-utils/semodule-utils-9999.ebuild
index db1d166cceb3..13fc0d86279e 100644
--- a/sys-apps/semodule-utils/semodule-utils-9999.ebuild
+++ b/sys-apps/semodule-utils/semodule-utils-9999.ebuild
@@ -1,25 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit toolchain-funcs
-MY_RELEASEDATE="20200710"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-
-MY_P="${P//_/-}"
IUSE=""
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN}"
+ S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
- S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="SELinux policy module utilities"
@@ -28,7 +22,7 @@ HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=">=sys-libs/libsepol-${SEPOL_VER}:="
+DEPEND=">=sys-libs/libsepol-${PV}:="
RDEPEND="${DEPEND}"