summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-09-04 19:34:05 +0200
committerDavid Seifert <soap@gentoo.org>2021-09-04 19:34:05 +0200
commitdb511bc85cc5bdde00114dac6898d4751298c1c6 (patch)
tree79b4f562ab6b6cc5672d26caf1154909ac8d1ab0 /sys-apps
parentsys-apps/help2man: drop 1.48.4 (diff)
downloadgentoo-db511bc85cc5bdde00114dac6898d4751298c1c6.tar.gz
gentoo-db511bc85cc5bdde00114dac6898d4751298c1c6.tar.bz2
gentoo-db511bc85cc5bdde00114dac6898d4751298c1c6.zip
sys-apps/kexec-tools: drop 2.0.21
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kexec-tools/Manifest1
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.21.ebuild124
2 files changed, 0 insertions, 125 deletions
diff --git a/sys-apps/kexec-tools/Manifest b/sys-apps/kexec-tools/Manifest
index cb80e9aa09d0..37a0cacee226 100644
--- a/sys-apps/kexec-tools/Manifest
+++ b/sys-apps/kexec-tools/Manifest
@@ -1,2 +1 @@
-DIST kexec-tools-2.0.21.tar.xz 303300 BLAKE2B d5b7bddeafdcbfd2b07dab6e4f167fcb61ccf2ec487f1835ac552a4596d22a94a7297d0eb769913f84eddc564ba4d9ae0c9d4c76994d0e3670fe168f377ebc77 SHA512 f487d2e243c2c4f29fbc9da7d06806f65210f717904655fc84d8d162b9c4614c3dd62e1bb47104a79f0dc2af04e462baf764fb309b5d7e6d287264cb48fd2a3e
DIST kexec-tools-2.0.22.tar.xz 303564 BLAKE2B 977c741eabf9b6b882550713ba59b18289b4f997fb382e96338efce6d04a9390fea952fc46ca72fd0a0b782261841ab2002da84b1819f955e63996eac900b0f7 SHA512 7580860f272eee5af52139809f12961e5a5d3a65f4e191183ca9c845410425d25818945ac14ed04a60e6ce474dc2656fc6a14041177b0bf703f450820c7d6aba
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.21.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.21.ebuild
deleted file mode 100644
index 897b98a24b69..000000000000
--- a/sys-apps/kexec-tools/kexec-tools-2.0.21.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit libtool linux-info systemd
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3 autotools
- EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
-else
- SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/kexec/${P/_/-}.tar.xz"
- [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="booke lzma xen zlib"
-
-REQUIRED_USE="lzma? ( zlib )"
-
-DEPEND="
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P/_/-}"
-
-CONFIG_CHECK="~KEXEC"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
- "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
-)
-
-pkg_setup() {
- # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
- export ASFLAGS="${CCASFLAGS}"
-}
-
-src_prepare() {
- default
-
- # Append PURGATORY_EXTRA_CFLAGS flags set by configure, instead of overriding them completely.
- sed -e "/^PURGATORY_EXTRA_CFLAGS =/s/=/+=/" -i Makefile.in || die
-
- if [[ "${PV}" == 9999 ]] ; then
- eautoreconf
- else
- elibtoolize
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with booke)
- $(use_with lzma)
- $(use_with xen)
- $(use_with zlib)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- # Respect CFLAGS for purgatory.
- # purgatory/Makefile uses PURGATORY_EXTRA_CFLAGS variable.
- # -mfunction-return=thunk and -mindirect-branch=thunk conflict with
- # -mcmodel=large which is added by build system.
- # Replace them with -mfunction-return=thunk-inline and -mindirect-branch=thunk-inline.
- local flag flags=()
- for flag in ${CFLAGS}; do
- [[ ${flag} == -mfunction-return=thunk ]] && flag="-mfunction-return=thunk-inline"
- [[ ${flag} == -mindirect-branch=thunk ]] && flag="-mindirect-branch=thunk-inline"
- flags+=("${flag}")
- done
- local -x PURGATORY_EXTRA_CFLAGS="${flags[*]}"
-
- default
-}
-
-src_install() {
- default
-
- dodoc "${FILESDIR}"/README.Gentoo
-
- newinitd "${FILESDIR}"/kexec-r2.init kexec
- newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
-
- insinto /etc
- doins "${FILESDIR}"/kexec.conf
-
- insinto /etc/kernel/postinst.d
- doins "${FILESDIR}"/90_kexec
-
- systemd_dounit "${FILESDIR}"/kexec.service
-}
-
-pkg_postinst() {
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "For systemd support the new config file is"
- elog " /etc/kexec.conf"
- elog "Please adopt it to your needs as there is no autoconfig anymore"
- fi
-
- local n_root_args=$(grep -o -- '\<root=' /proc/cmdline 2>/dev/null | wc -l)
- local has_rootpart_set=no
- if [[ -f "${EROOT}/etc/conf.d/kexec" ]]; then
- if grep -q -E -- '^ROOTPART=' "${EROOT}/etc/conf.d/kexec" 2>/dev/null; then
- has_rootpart_set=yes
- fi
- fi
-
- if [[ ${n_root_args} > 1 && "${has_rootpart_set}" == "no" ]]; then
- ewarn "WARNING: Multiple root arguments (root=) on kernel command-line detected!"
- ewarn "This was probably caused by a previous version of ${PN}."
- ewarn "Please reboot system once *without* kexec to avoid boot problems"
- ewarn "in case running system and initramfs do not agree on detected"
- ewarn "root device name!"
- fi
-}