summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-02 11:16:17 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-02 11:17:16 +0100
commite21acb7da107e7e9d2bc7f8b69dd2f83a8333f88 (patch)
treeed5f2ca6ad77f763334e22111307b15ebc652ebb /sys-apps
parentsys-fs/cryptsetup: Bump to version 2.2.2 (diff)
downloadgentoo-e21acb7da107e7e9d2bc7f8b69dd2f83a8333f88.tar.gz
gentoo-e21acb7da107e7e9d2bc7f8b69dd2f83a8333f88.tar.bz2
gentoo-e21acb7da107e7e9d2bc7f8b69dd2f83a8333f88.zip
sys-apps/fwupd: Bump to version 1.3.3
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fwupd/Manifest1
-rw-r--r--sys-apps/fwupd/fwupd-1.3.3.ebuild156
2 files changed, 157 insertions, 0 deletions
diff --git a/sys-apps/fwupd/Manifest b/sys-apps/fwupd/Manifest
index bd80e75ecc88..a9629791b8f2 100644
--- a/sys-apps/fwupd/Manifest
+++ b/sys-apps/fwupd/Manifest
@@ -2,3 +2,4 @@ DIST fwupd-1.2.10.tar.gz 1943920 BLAKE2B 5aec740c777d8749901ee35915f3510998b7477
DIST fwupd-1.2.11.tar.gz 1945646 BLAKE2B 4eb6d5008d0e515880147a94b2632ed70b5f7ab1891775ac121347653c06bf4403ab7f4a1fe160000a6195d360fe06d64c8971dd53c1538aeac40d155f59979a SHA512 a8d6a76ac59937547c6866d414e95a67779574901b0a15ecfde763f49b434b284be2ade1194179225785006e5f93836667469d08f32d4c87fc85927aa0bfe9de
DIST fwupd-1.2.8.tar.gz 1911999 BLAKE2B 61a24ce24f778b96f7ad23496890f7a1d20c09e6bbd707f29d154992668d5c0a25cfd31b5d0d11519740e086c098cbdfd440fe9f5cab4dde0ac43fe6b438e911 SHA512 d603f9f4e5a4c0fc6abb0b75f7d884eff47fb8a16285aa545f7140fe98ce781d127ff3769f9c206bb3bfd084bbc5bf6abf9424f70e727ff79162416fe7881154
DIST fwupd-1.3.2.tar.gz 2100817 BLAKE2B 49441603ac0934a10b730b82b4f86cbdac03c3ab9de6051af6ca0c5f3d610cda1a619b7f0af9de61de3bd926175cf37523f47cf3fe2743ae54e5327d5ae8a518 SHA512 5b302d0ba1eb10f3ec440ed1a5ad25b5a9398c7601dc2e058d0df57e16a2e3b65ab3b7e93a07300e3db21789909fc2a72feebab0271fa0669dd792f290506c1b
+DIST fwupd-1.3.3.tar.gz 2125604 BLAKE2B 4471d270ec7f99857dd811b2ba9d8f591a0787ee7ad2bf45edff90904483b8fe54483cde2722e7ee9afb426b17b4d4090f6935b3fa2712a277d058802fc2e9f5 SHA512 b8f0d88fa9c1c8219dd040775d76207f1be87294ebb5f38043b77a670a1601cc597a711f5635aa3d164a08ee0dd068dd22514acae96f6fc5ad20d35099d02f50
diff --git a/sys-apps/fwupd/fwupd-1.3.3.ebuild b/sys-apps/fwupd/fwupd-1.3.3.ebuild
new file mode 100644
index 000000000000..b1c77f7d52de
--- /dev/null
+++ b/sys-apps/fwupd/fwupd-1.3.3.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit linux-info meson python-single-r1 vala xdg
+
+DESCRIPTION="Aims to make updating firmware on Linux automatic, safe and reliable"
+HOMEPAGE="https://fwupd.org"
+SRC_URI="https://github.com/hughsie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="agent amt consolekit dell gtk-doc elogind minimal +gpg introspection +man nvme pkcs7 redfish synaptics systemd test thunderbolt uefi"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ^^ ( consolekit elogind minimal systemd )
+ dell? ( uefi )
+ minimal? ( !introspection )
+"
+RESTRICT="!test? ( test )"
+
+BDEPEND="$(vala_depend)
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+ man? (
+ app-text/docbook-sgml-utils
+ sys-apps/help2man
+ )
+ test? (
+ thunderbolt? ( dev-util/umockdev )
+ net-libs/gnutls[tools]
+ )
+"
+DEPEND="${PYTHON_DEPS}
+ >=app-arch/gcab-1.0
+ app-arch/libarchive:=
+ dev-db/sqlite
+ >=dev-libs/glib-2.45.8:2
+ dev-libs/json-glib
+ dev-libs/libgpg-error
+ dev-libs/libgudev:=
+ >=dev-libs/libgusb-0.2.9[introspection?]
+ >=dev-libs/libxmlb-0.1.7
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=net-libs/libsoup-2.51.92:2.4[introspection?]
+ virtual/libelf:0=
+ virtual/udev
+ consolekit? ( >=sys-auth/consolekit-1.0.0 )
+ dell? (
+ sys-libs/efivar
+ >=sys-libs/libsmbios-2.4.0
+ )
+ elogind? ( sys-auth/elogind )
+ gpg? (
+ app-crypt/gpgme
+ dev-libs/libgpg-error
+ )
+ !minimal? (
+ >=sys-auth/polkit-0.103
+ )
+ nvme? ( sys-libs/efivar )
+ pkcs7? ( >=net-libs/gnutls-3.4.4.1:= )
+ redfish? ( sys-libs/efivar )
+ systemd? ( >=sys-apps/systemd-211 )
+ thunderbolt? (
+ sys-apps/thunderbolt-software-user-space
+ )
+ uefi? (
+ app-crypt/tpm2-tss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-boot/gnu-efi
+ sys-boot/efibootmgr
+ >=sys-libs/efivar-33
+ x11-libs/cairo
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/dbus
+"
+
+pkg_setup() {
+ if use nvme; then
+ kernel_is -ge 4 4 || die "NVMe support requires kernel >= 4.4"
+ fi
+}
+
+src_prepare() {
+ default
+ # c.f. https://github.com/fwupd/fwupd/issues/1414
+ sed -e "/test('thunderbolt-self-test', e, env: test_env, timeout : 120)/d" \
+ -i plugins/thunderbolt/meson.build || die
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ --localstatedir "${EPREFIX}"/var
+ -Dbuild="$(usex minimal standalone all)"
+ $(meson_use agent)
+ $(meson_use amt plugin_amt)
+ $(meson_use consolekit)
+ $(meson_use dell plugin_dell)
+ $(meson_use elogind)
+ $(meson_use gpg)
+ $(meson_use gtk-doc gtkdoc)
+ $(meson_use man)
+ $(meson_use nvme plugin_nvme)
+ $(meson_use pkcs7)
+ $(meson_use redfish plugin_redfish)
+ $(meson_use synaptics plugin_synaptics)
+ $(meson_use systemd)
+ $(meson_use test tests)
+ $(meson_use thunderbolt plugin_thunderbolt)
+ $(meson_use uefi plugin_uefi)
+ # Requires libflashrom which our sys-apps/flashrom
+ # package does not provide
+ -Dplugin_flashrom="false"
+ # Dependencies are not available (yet?)
+ -Dplugin_modem_manager="false"
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use minimal ; then
+ sed "s@%SEAT_MANAGER%@$(usex elogind elogind consolekit)@" \
+ "${FILESDIR}"/${PN}-r1 \
+ > "${T}"/${PN} || die
+ doinitd "${T}"/${PN}
+
+ if ! use systemd ; then
+ # Don't timeout when fwupd is running (#673140)
+ sed '/^IdleTimeout=/s@=[[:digit:]]\+@=0@' \
+ -i "${ED}"/etc/${PN}/daemon.conf || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "In case you are using openrc as init system"
+ elog "and you're upgrading from <fwupd-1.1.0, you"
+ elog "need to start the fwupd daemon via the openrc"
+ elog "init script that comes with this package."
+}