summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-09-17 04:17:45 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-09-17 04:17:45 +0200
commite8fe85a3d1da3f58f2c8e94fc8bd308c080b0bf8 (patch)
treeb7aa988bbd2d0ae1f3588293d40c7262a73b37d8 /sys-apps
parentapp-arch/sharutils: Enforce -Wno-error=format-security (diff)
downloadgentoo-e8fe85a3d1da3f58f2c8e94fc8bd308c080b0bf8.tar.gz
gentoo-e8fe85a3d1da3f58f2c8e94fc8bd308c080b0bf8.tar.bz2
gentoo-e8fe85a3d1da3f58f2c8e94fc8bd308c080b0bf8.zip
sys-apps/fakeroot: Bump to v1.22
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fakeroot/Manifest1
-rw-r--r--sys-apps/fakeroot/fakeroot-1.22.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/Manifest b/sys-apps/fakeroot/Manifest
index 1e33a114419a..36907c3e3842 100644
--- a/sys-apps/fakeroot/Manifest
+++ b/sys-apps/fakeroot/Manifest
@@ -2,3 +2,4 @@ DIST fakeroot_1.18.4.orig.tar.bz2 309298 SHA256 0a359efa3e9496c33234b3e9c89306a0
DIST fakeroot_1.19.orig.tar.bz2 312304 SHA256 eafa6885535ff57a42248aec090fe17cfa5ca85b62cefa0d13637c9de8996868 SHA512 ff3f50cdf168deafab337d3d98299ccd4129ed2a9befa5f28171d92c2ddfa08c8f42424f32b3fbcbb1f83c16f22952e571946f4152246d08b0d18bab77c458e9 WHIRLPOOL 4fcce88f114a87a07698eede3ab384621bfff4cc3fa478c5b162e95c4901bc75647c7e7c69c8196885d96acd0658b5f3cba50e46973e010d0e4adc3f49729e00
DIST fakeroot_1.20.2.orig.tar.bz2 326910 SHA256 7c0a164d19db3efa9e802e0fc7cdfeff70ec6d26cdbdc4338c9c2823c5ea230c SHA512 1ac231f995774aa40f43c4325cd9e6de45365963277c32a85776690c3e7fd281ac410f3d91395dc1e5e5ca3b143e89914e048632011a3985ead216e870852231 WHIRLPOOL b39d8682e13d69648f60ff70853b2588b9e638112b8874794e1c6bccb6c060868ee81031887cb7aacf78d2fa2ec9f00c4103655d24406d001e076c43b4ca6c1d
DIST fakeroot_1.20.orig.tar.bz2 321491 SHA256 2297b7e79487cf0bbc64ff6d3d02446d895e82e2b26467c74fd1119011f6f098 SHA512 b041ab87559f784041f05bfa9d5186ceaafebbcbd03057ede62bf420551e337ceec4b7101854937e206c6389ac2c0719545d5971457edaf564856bb44ce7b4b6 WHIRLPOOL 00b55e38004b3bb843e06299e014fb776150efc398b42099fa1772c4999aa3282a244c0987123f33aee9f844351dd9a31cf6c218c3439aebf1cba2c633a2b7bb
+DIST fakeroot_1.22.orig.tar.bz2 338238 SHA256 bd806a4a1e641203eb3d4571a10089e8a038c10ec7e492fa1e061b03ae3ec6fe SHA512 193478d9ff88ca2ae69fe47b73b6c61aeb2ba3f2a9e7ed5d455022705857c6f34cdcbe2d3f614c4c4c9509368dc78b9a7b7aa56fb3b50bb3309448140abd796a WHIRLPOOL ad09ceabd14e6e144aaaf07fd24b973565ef027f69769192f67b7b5c76c04716e7c6d9d3a1ff8cd7ee090665a7654d469381fdfc2625345bc18a3b78c40ec231
diff --git a/sys-apps/fakeroot/fakeroot-1.22.ebuild b/sys-apps/fakeroot/fakeroot-1.22.ebuild
new file mode 100644
index 000000000000..be4446fbe1f7
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.22.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug static-libs test"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )"
+
+DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19-no-acl_h.patch
+ "${FILESDIR}"/${PN}-1.20.2-glibc-2.24.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+
+ use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+}