summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-02-07 12:00:25 -0500
committerMike Gilbert <floppym@gentoo.org>2020-02-07 12:00:25 -0500
commite94d3855452a0398e3764d7b4a9034c9808bc050 (patch)
treedb5c4533f93a0b76f8d4fb35d3647efcc6c45dde /sys-apps
parentsys-fs/udiskie: bump to 2.1.0 (diff)
downloadgentoo-e94d3855452a0398e3764d7b4a9034c9808bc050.tar.gz
gentoo-e94d3855452a0398e3764d7b4a9034c9808bc050.tar.bz2
gentoo-e94d3855452a0398e3764d7b4a9034c9808bc050.zip
sys-apps/coreutils: simplify python_check_deps
pkg_setup already checks the 'test' USE flag, so we don't need to do it again. Bug: https://bugs.gentoo.org/708588 Package-Manager: Portage-2.3.86_p1, Repoman-2.3.20_p43 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-8.30.ebuild4
-rw-r--r--sys-apps/coreutils/coreutils-8.31-r1.ebuild4
-rw-r--r--sys-apps/coreutils/coreutils-8.31.ebuild4
3 files changed, 3 insertions, 9 deletions
diff --git a/sys-apps/coreutils/coreutils-8.30.ebuild b/sys-apps/coreutils/coreutils-8.30.ebuild
index 6c40cc430002..03b60ae85543 100644
--- a/sys-apps/coreutils/coreutils-8.30.ebuild
+++ b/sys-apps/coreutils/coreutils-8.30.ebuild
@@ -55,9 +55,7 @@ RDEPEND+="
!<net-fs/netatalk-2.0.3-r4"
python_check_deps() {
- if use test; then
- has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
- fi
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/sys-apps/coreutils/coreutils-8.31-r1.ebuild b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
index 5860f7daa1b5..b41b9ca21bf0 100644
--- a/sys-apps/coreutils/coreutils-8.31-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
@@ -53,9 +53,7 @@ RDEPEND+="
!<net-fs/netatalk-2.0.3-r4"
python_check_deps() {
- if use test; then
- has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
- fi
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/sys-apps/coreutils/coreutils-8.31.ebuild b/sys-apps/coreutils/coreutils-8.31.ebuild
index eb8a90e46999..31a4e5355488 100644
--- a/sys-apps/coreutils/coreutils-8.31.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31.ebuild
@@ -55,9 +55,7 @@ RDEPEND+="
!<net-fs/netatalk-2.0.3-r4"
python_check_deps() {
- if use test; then
- has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
- fi
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
}
pkg_setup() {