summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-10-03 20:01:01 -0400
committerMike Gilbert <floppym@gentoo.org>2022-10-03 20:01:01 -0400
commiteedb1adf2f4fca6d557ba8a2f5cca00011877ecc (patch)
treef22fa4056daa3c169d19c40b0fab80b1b181b2f4 /sys-apps
parentprofiles/features/musl: mask wireshark[sdjournal], needs masked systemd (diff)
downloadgentoo-eedb1adf2f4fca6d557ba8a2f5cca00011877ecc.tar.gz
gentoo-eedb1adf2f4fca6d557ba8a2f5cca00011877ecc.tar.bz2
gentoo-eedb1adf2f4fca6d557ba8a2f5cca00011877ecc.zip
sys-apps/systemd: fix install with USE="-resolvconf -sysv-utils -split-usr"
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/systemd-251.4.ebuild2
-rw-r--r--sys-apps/systemd/systemd-251.5.ebuild2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/systemd/systemd-251.4.ebuild b/sys-apps/systemd/systemd-251.4.ebuild
index 487bf56cfcf6..04ba0014612b 100644
--- a/sys-apps/systemd/systemd-251.4.ebuild
+++ b/sys-apps/systemd/systemd-251.4.ebuild
@@ -389,7 +389,7 @@ multilib_src_install_all() {
rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 || die
fi
- if ! use resolvconf && ! use sysv-utils && ! use split-usr; then
+ if ! use resolvconf && ! use sysv-utils && use split-usr; then
rmdir "${ED}${rootprefix}"/sbin || die
fi
diff --git a/sys-apps/systemd/systemd-251.5.ebuild b/sys-apps/systemd/systemd-251.5.ebuild
index df1093c4548c..41bd8eea2783 100644
--- a/sys-apps/systemd/systemd-251.5.ebuild
+++ b/sys-apps/systemd/systemd-251.5.ebuild
@@ -389,7 +389,7 @@ multilib_src_install_all() {
rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 || die
fi
- if ! use resolvconf && ! use sysv-utils && ! use split-usr; then
+ if ! use resolvconf && ! use sysv-utils && use split-usr; then
rmdir "${ED}${rootprefix}"/sbin || die
fi
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 733ffd2c153a..d4f1b4c5d629 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -386,7 +386,7 @@ multilib_src_install_all() {
rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 || die
fi
- if ! use resolvconf && ! use sysv-utils && ! use split-usr; then
+ if ! use resolvconf && ! use sysv-utils && use split-usr; then
rmdir "${ED}${rootprefix}"/sbin || die
fi