summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-09-11 22:53:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-09-11 22:57:52 +0200
commitf3ed1d20a91c47f01b8f3d81d721b591c99ba5be (patch)
treed1ce7392b4bdbe59be91e528070fb784e9790b41 /sys-apps
parentapp-crypt/gnupg: Version bump to 2.0.29 (diff)
downloadgentoo-f3ed1d20a91c47f01b8f3d81d721b591c99ba5be.tar.gz
gentoo-f3ed1d20a91c47f01b8f3d81d721b591c99ba5be.tar.bz2
gentoo-f3ed1d20a91c47f01b8f3d81d721b591c99ba5be.zip
sys-apps/help2man: Bump to version 1.47.2
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/help2man/Manifest1
-rw-r--r--sys-apps/help2man/help2man-1.47.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 8b80692a70d9..834e9e6ae037 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1,3 +1,4 @@
DIST help2man-1.45.1.tar.xz 124236 SHA256 c70fc791e6d13240327955de355244371b00bb1c9e247d5693ed601b716467c2 SHA512 728f8d464369752ac680cafc151f84bc9edddae1fb57621d5179346dd50f735b8ced0b7f46456cb6201e43cfdeb33b3cc155513aa76152889501952277774c08 WHIRLPOOL 1ded36ab4eb934462bba4e1b3d3f6168411931465c8cc60ca0ca86afe505e3fdab6607cefdaed6f38b004d9ce6f91772cfe036c248d2c73fae452f73387a6455
DIST help2man-1.46.6.tar.xz 171044 SHA256 615ff5ac38369ddb3707c5fd71672ab122639fd9cf6870de172e0127ed632caf SHA512 55bea01b80baf318e4350ee505bf67da9a7e76b7a5cbd861d0fd6e3afe47b82d1de8f1079d0df2f4ea8ec176d6ca95d5c847d8b1c118cf96ab59b06567c1204c WHIRLPOOL 91d4702d69457090ca58074c05763a085e5bd9da162253a14e86c618a619482e44d7d974c7b0fd0139927d5a67b48bc7160f50990bb622984b122d1bb6c7052c
DIST help2man-1.47.1.tar.xz 179164 SHA256 c59b26f60cb06e45b00e729dea721e7a17220e2c17d800eb428271a750382b06 SHA512 3ac99d2d2384aea9d396c7fb123f17b99c19db8f18085be3516cef56f2ecf06f16e6aa924b41b53f57eca8722dee029939677401dd69358cddc39fc59e0bcf12 WHIRLPOOL 75a21cfc55e2652a02f12075a3609dcb4c9f42fdea02fdbda0757cf2f107602e609f4ed9641351663fe177936353db0cb26b763bae92a83bbd2f6ffe0bf7e941
+DIST help2man-1.47.2.tar.xz 182356 SHA256 c4c5606773e51039a06b7328ed4934913df142747a9a185d2a6ab9300d7f3f7c SHA512 3429e8f2eff78c8ab8d93533411b68aa8c1f730e56a261de82908069d6ce1af15443f8cc618d1b6f1d8fdc9a06631c9550520f7f43b984f91f2a1778d1c1402e WHIRLPOOL c14cff9fa52756c457c09d976c870ec25d9f66ec44417a3762d361c0edd4f8ddc0d0a6a95233a8e9ca6bcd796336c4f48c4211d1d21bc148487669c0113b630d
diff --git a/sys-apps/help2man/help2man-1.47.2.ebuild b/sys-apps/help2man/help2man-1.47.2.ebuild
new file mode 100644
index 000000000000..82ad4a58f1ad
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.47.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND=${RDEPEND}
+
+DOCS="debian/changelog NEWS README THANKS" #385753
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ econf \
+ ac_cv_path_MSGFMT=$(type -P false) \
+ $(use_enable nls)
+}