summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:50:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:51:18 +0200
commitfc28a1267b5ec196edf1765d112fc2abda4f5e40 (patch)
tree3f9e4f646aa677ebfa6e151f26d42426388fe54d /sys-apps
parentmedia-gfx/icoutils: Bump to version 0.31.3 (diff)
downloadgentoo-fc28a1267b5ec196edf1765d112fc2abda4f5e40.tar.gz
gentoo-fc28a1267b5ec196edf1765d112fc2abda4f5e40.tar.bz2
gentoo-fc28a1267b5ec196edf1765d112fc2abda4f5e40.zip
sys-apps/gsmartcontrol: Bump to version 1.0.2
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gsmartcontrol/Manifest1
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/Manifest b/sys-apps/gsmartcontrol/Manifest
index 7a63c6160a87..c3a031ce3521 100644
--- a/sys-apps/gsmartcontrol/Manifest
+++ b/sys-apps/gsmartcontrol/Manifest
@@ -1,3 +1,4 @@
DIST gsmartcontrol-0.8.7.tar.bz2 684394 SHA256 708fa803243abb852ed52050fc82cd3592a798c02743342441996e77f19ffec6 SHA512 3258ddcb448460afeef8d617ab5bb4720c9b2444452bc45d6798ec645da4862236fbb3fe0116a1cc904f5353481df87603bd2b6d808f348c250bde3624c8403a WHIRLPOOL 24fb546c7175306c8cdd8906b506471d20668de0cd078a8205ec87eff50ce0eb52dc04b3b05e771f8789ef852e5f97675c7c224ab6450d90a3e2ac3e51578d2a
DIST gsmartcontrol-0.9.0.tar.bz2 710515 SHA256 5da6435aa0845acef134f72c2b5f6fce79f9c51bebe9d099402e0f21a3388651 SHA512 c7a6f4dbb748bdef14a3a18a98d30f8ba8595017c99d7ac6817a33d537f19ab55d2c5674fb1f44f77381e54e22b894d8cca700554186a8132b04249001fcda98 WHIRLPOOL 2b9e926e86bbd351ec3ed331abec508cbc129e1ca340106ffa2cd8aa8f9db13c721512f8afa4e70cd83ea1ae855e0fb494223264129ce6a583fb717d69d2a1ca
DIST gsmartcontrol-1.0.1.tar.bz2 691628 SHA256 4ec0320c4c40a129cacabbfa7f302146abb69e927cfe9ded0e55b5b9cbe0d949 SHA512 151eb08b61616189ff3eaab59e186e609fed0d2081a85b8c9cba0aa2efb1b1742c1def99a52def9138c3bffe5caabe9ca78d764dbe3b138fc9401135b8ab85aa WHIRLPOOL b49eb8e8c59183dcfa902f8cb98596f4f99adbb084ba517314f9be0e24a8022d3fc73f807facf405d107467c969d7abc642ef621a2218105234bef4edd8bd949
+DIST gsmartcontrol-1.0.2.tar.bz2 695445 SHA256 4f70451c359d95edc974498b860696b698f19b187340dc7207b4b38cbaf5e207 SHA512 a9dd037fc4223afa762408bc34325fb31947822250efe32ae97b88e836c5bb68d8354d7605925b2ab7c834764ea473a14f2cd1f234577ef76730b02ad9a8b701 WHIRLPOOL 679c6b9fa739f624a1bc523d0c17454cdf69e5899e086044c134116c609aaaf1a4dfec48813bc9b76210b1023623c626a4d9b55bbffa8c603c0340549eb5a028
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild
new file mode 100644
index 000000000000..bbfa1f5ffda3
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="http://gsmartcontrol.sourceforge.net/home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/libpcre:3
+ sys-apps/smartmontools
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xmessage
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )
+"
+
+DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
+
+src_prepare() {
+ default
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ econf $(use test tests)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }