summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/bioapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/bioapi')
-rw-r--r--sys-auth/bioapi/Manifest2
-rw-r--r--sys-auth/bioapi/bioapi-1.2.3-r2.ebuild79
-rw-r--r--sys-auth/bioapi/bioapi-1.2.4.ebuild77
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.3-build.patch42
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch16
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.3-gcc44.patch12
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch15
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.4-build.patch42
-rw-r--r--sys-auth/bioapi/metadata.xml11
9 files changed, 296 insertions, 0 deletions
diff --git a/sys-auth/bioapi/Manifest b/sys-auth/bioapi/Manifest
new file mode 100644
index 000000000000..35e1927dc612
--- /dev/null
+++ b/sys-auth/bioapi/Manifest
@@ -0,0 +1,2 @@
+DIST bioapi_1.2.3.tar.gz 1634237 SHA256 c780c0d2e0c676be50de8ff537653580dd5b27fe1478846d22a017e52c6b6c2e SHA512 683da884a5cf6d72b577f7c1f642930c152c43c7acad3c678a3571acf3f66e0a7e112fccde06d9a7535a186bcb56a96acfb5e1c405b1d931be9f252be1b01649 WHIRLPOOL 9162097a90ce089ab9864034dae434fc55c593c33f8d618c6f1e62f3202a7e3294680df992b684df507705c26e7fb897e85a95552c12fc545ab6ba06df445970
+DIST bioapi_1.2.4.tar.gz 953136 SHA256 ec39d82deaacdd3dea676bdfcce69d34cbb745580735b59b44c542a6de35008d SHA512 99c67fea34b73291dcaeb1590fac88b3196d3ca65f788b92d0afd6ba85036b2d85397e3faa66b872a68bffaeb7c2bf5c731306bf02a25a435ef06cea18da746f WHIRLPOOL 08526484cb6240f45e48ca894602c4706319d4ac7297592740836e48ff4794a2f12fee165eb358732b0d31d1619d7f3743aa55d32ba6d79b405a553e0992b517
diff --git a/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild b/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..ea07a7e42a38
--- /dev/null
+++ b/sys-auth/bioapi/bioapi-1.2.3-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils multilib user
+
+DESCRIPTION="Framework for biometric-based authentication"
+HOMEPAGE="http://code.google.com/p/bioapi-linux/"
+SRC_URI="http://bioapi-linux.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="bioapi"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/bioapi-linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-enroll-ret.patch #236654
+ epatch "${FILESDIR}"/${P}-no-delete.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-build.patch #336107
+ rm -f config.{guess,sub} #337805
+ touch config.{guess,sub}
+}
+
+src_configure() {
+ econf --without-Qt-dir
+}
+
+src_install() {
+ emake SKIPCONFIG=true DESTDIR="${D}" install || die
+ dodoc README
+ dohtml *.htm
+
+ # rename generic binaries
+ mv "${D}"/usr/bin/{,BioAPI}Sample || die
+}
+
+pkg_config() {
+ mds_install -s /usr/$(get_libdir)
+ mod_install -fi /usr/$(get_libdir)/libbioapi100.so
+ mod_install -fi /usr/$(get_libdir)/libbioapi_dummy100.so
+ mod_install -fi /usr/$(get_libdir)/libpwbsp.so
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/var/bioapi ]] && [[ ! -e ${ROOT}/var/lib/bioapi ]] ; then
+ einfo "Moving /var/bioapi to /var/lib/bioapi"
+ dodir /var/lib
+ mv "${ROOT}"/var/bioapi "${ROOT}"/var/lib/bioapi
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some generic-named programs have been renamed:"
+ einfo " Sample -> BioAPISample"
+
+ if [[ ${ROOT} == "/" ]] ; then
+ pkg_config
+ else
+ ewarn "You will need to run 'emerge --config bioapi' before"
+ ewarn " you can use bioapi properly."
+ fi
+
+ # XXX: this can't be correct ...
+ enewgroup bioapi
+ chgrp bioapi "${ROOT}"/var/lib/bioapi -R
+ chmod g+w,o= "${ROOT}"/var/lib/bioapi -R
+ einfo "Note: users using bioapi must be in group bioapi."
+}
+
+pkg_prerm() {
+ mod_install -fu libbioapi100.so
+ mod_install -fu libbioapi_dummy100.so
+ mod_install -fu libpwbsp.so
+}
diff --git a/sys-auth/bioapi/bioapi-1.2.4.ebuild b/sys-auth/bioapi/bioapi-1.2.4.ebuild
new file mode 100644
index 000000000000..4f2087063cc1
--- /dev/null
+++ b/sys-auth/bioapi/bioapi-1.2.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib user
+
+DESCRIPTION="Framework for biometric-based authentication"
+HOMEPAGE="http://code.google.com/p/bioapi-linux/"
+SRC_URI="http://bioapi-linux.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="bioapi"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+S=${WORKDIR}/bioapi-linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.3-no-delete.patch
+ epatch "${FILESDIR}"/${PN}-1.2.4-build.patch #336107
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --without-Qt-dir
+}
+
+src_install() {
+ SKIPCONFIG=true default
+ use static-libs || find "${ED}" -name '*.la' -delete
+ dohtml *.htm
+
+ # rename generic binaries
+ mv "${D}"/usr/bin/{,BioAPI}Sample || die
+}
+
+pkg_config() {
+ mds_install -s /usr/$(get_libdir)
+ mod_install -fi /usr/$(get_libdir)/libbioapi100.so
+ mod_install -fi /usr/$(get_libdir)/libbioapi_dummy100.so
+ mod_install -fi /usr/$(get_libdir)/libpwbsp.so
+}
+
+pkg_preinst() {
+ if [[ -e ${EROOT}/var/bioapi ]] && [[ ! -e ${EROOT}/var/lib/bioapi ]] ; then
+ einfo "Moving /var/bioapi to /var/lib/bioapi"
+ dodir /var/lib
+ mv "${ROOT}"/var/bioapi "${ROOT}"/var/lib/bioapi
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some generic-named programs have been renamed:"
+ einfo " Sample -> BioAPISample"
+
+ if [[ ${EROOT} == "/" ]] ; then
+ pkg_config
+ else
+ ewarn "You will need to run 'emerge --config bioapi' before"
+ ewarn " you can use bioapi properly."
+ fi
+
+ # XXX: this can't be correct ...
+ enewgroup bioapi
+ chgrp bioapi "${EROOT}"/var/lib/bioapi -R
+ chmod g+w,o= "${EROOT}"/var/lib/bioapi -R
+ einfo "Note: users using bioapi must be in group bioapi."
+}
+
+pkg_prerm() {
+ mod_install -fu libbioapi100.so
+ mod_install -fu libbioapi_dummy100.so
+ mod_install -fu libpwbsp.so
+}
diff --git a/sys-auth/bioapi/files/bioapi-1.2.3-build.patch b/sys-auth/bioapi/files/bioapi-1.2.3-build.patch
new file mode 100644
index 000000000000..9d679fe8c892
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.3-build.patch
@@ -0,0 +1,42 @@
+http://code.google.com/p/bioapi-linux/issues/detail?id=4
+
+--- a/addins/pwbsp/Makefile.in
++++ b/addins/pwbsp/Makefile.in
+@@ -87,7 +87,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include/ \
++AM_CPPFLAGS = -I${top_srcdir}/include/ \
+ -I${top_srcdir}/imports/cdsa/v2_0/inc/
+
+ CXX = @CXX@
+@@ -111,7 +111,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
+ LEX = @LEX@
+ LEXLIB = @LEXLIB@
+ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
+--- a/addins/qtpwbsp/Makefile.in
++++ b/addins/qtpwbsp/Makefile.in
+@@ -96,7 +96,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include \
++AM_CPPFLAGS = -I${top_srcdir}/include \
+ -I${top_srcdir}/imports/cdsa/v2_0/inc \
+ ${QT_CXXFLAGS}
+
+@@ -121,7 +121,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
+ ${QT_LIBS}
+
+ LEX = @LEX@
diff --git a/sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch b/sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch
new file mode 100644
index 000000000000..e077c135d63f
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/236654
+
+make sure we return 0 when things work
+
+patch by kouyu
+
+--- bioapi-linux/apps/NonGUI_Sample/main.c
++++ bioapi-linux/apps/NonGUI_Sample/main.c
+@@ -234,6 +234,7 @@
+ }
+
+ OutputToFile(userName, EnrolledTemplate);
++ return 0;
+ }
+ }
+
diff --git a/sys-auth/bioapi/files/bioapi-1.2.3-gcc44.patch b/sys-auth/bioapi/files/bioapi-1.2.3-gcc44.patch
new file mode 100644
index 000000000000..1f81298066dc
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.3-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur bioapi-linux.orig/framework/mds_util_api/mds_app_util.c bioapi-linux/framework/mds_util_api/mds_app_util.c
+--- bioapi-linux.orig/framework/mds_util_api/mds_app_util.c 2007-07-14 08:06:14.000000000 +0300
++++ bioapi-linux/framework/mds_util_api/mds_app_util.c 2009-07-25 23:26:55.000000000 +0300
+@@ -28,7 +28,7 @@
+ /* Linux-Port: added "const" keyword for Linux version */
+ #if defined (UNIX)
+ const BioAPI_UUID MDSUTIL_Uuid = ref_h_layer_uuid_init;
+-#elif
++#else
+ BioAPI_UUID MDSUTIL_Uuid = ref_h_layer_uuid_init;
+ #endif
+
diff --git a/sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch b/sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch
new file mode 100644
index 000000000000..b5664d11ec3a
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.3-no-delete.patch
@@ -0,0 +1,15 @@
+do not delete the installed symlink -- let the package manager handle that
+
+--- bioapi-linux/apps/mod_install/install.c
++++ bioapi-linux/apps/mod_install/install.c
+@@ -496,10 +496,6 @@
+ }
+ else if ( Action == INSTALL_ACTION_UNINSTALL )
+ {
+-/* Linux-Port: Added the Linux branch */
+-#if defined (LINUX) || defined (SOLARIS)
+- DeleteFile(szDstPath);
+-#endif
+ printf( "Module uninstalled successfully.\n" );
+ }
+ else if ( Action == INSTALL_ACTION_REFRESH )
diff --git a/sys-auth/bioapi/files/bioapi-1.2.4-build.patch b/sys-auth/bioapi/files/bioapi-1.2.4-build.patch
new file mode 100644
index 000000000000..d7a70afd4d0d
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.4-build.patch
@@ -0,0 +1,42 @@
+http://code.google.com/p/bioapi-linux/issues/detail?id=4
+
+--- a/addins/pwbsp/Makefile.in
++++ b/addins/pwbsp/Makefile.in
+@@ -87,7 +87,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include/ \
++AM_CPPFLAGS = -I${top_srcdir}/include/ \
+ -I${top_srcdir}/imports/cdsa/v2_0/inc/
+
+ CXX = @CXX@
+@@ -111,7 +111,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LD = @LD@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
+ LEX = @LEX@
+ LEXLIB = @LEXLIB@
+ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
+--- a/addins/qtpwbsp/Makefile.in
++++ b/addins/qtpwbsp/Makefile.in
+@@ -96,7 +96,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include \
++AM_CPPFLAGS = -I${top_srcdir}/include \
+ -I${top_srcdir}/imports/cdsa/v2_0/inc \
+ ${QT_CXXFLAGS}
+
+@@ -121,7 +121,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LD = @LD@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
+ ${QT_LIBS}
+
+ LEX = @LEX@
diff --git a/sys-auth/bioapi/metadata.xml b/sys-auth/bioapi/metadata.xml
new file mode 100644
index 000000000000..9a34902f8fa6
--- /dev/null
+++ b/sys-auth/bioapi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">bioapi-linux</remote-id>
+ </upstream>
+</pkgmetadata>