summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 20:09:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 20:11:35 +0100
commitc69127a348a81e7374e4746effd9add4299696c2 (patch)
treefcb86a2af22dfd1afc80c562375489e8113f4bc2 /sys-auth/elogind
parentapp-portage/eclass-manpages: Add a snapshot of today's manpages, #612424 (diff)
downloadgentoo-c69127a348a81e7374e4746effd9add4299696c2.tar.gz
gentoo-c69127a348a81e7374e4746effd9add4299696c2.tar.bz2
gentoo-c69127a348a81e7374e4746effd9add4299696c2.zip
sys-auth/elogind: Backport sysmacros.h fix from systemd
Gentoo-bug: 613422 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-auth/elogind')
-rw-r--r--sys-auth/elogind/elogind-226.4.ebuild5
-rw-r--r--sys-auth/elogind/files/elogind-226.4-glibc.patch34
2 files changed, 38 insertions, 1 deletions
diff --git a/sys-auth/elogind/elogind-226.4.ebuild b/sys-auth/elogind/elogind-226.4.ebuild
index 7b284e007ac8..2570aaccad3b 100644
--- a/sys-auth/elogind/elogind-226.4.ebuild
+++ b/sys-auth/elogind/elogind-226.4.ebuild
@@ -37,7 +37,10 @@ DEPEND="${COMMON_DEPEND}
"
PDEPEND="policykit? ( sys-auth/polkit )"
-PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-docs.patch"
+ "${FILESDIR}/${P}-glibc.patch"
+)
pkg_setup() {
local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SECURITY_SMACK
diff --git a/sys-auth/elogind/files/elogind-226.4-glibc.patch b/sys-auth/elogind/files/elogind-226.4-glibc.patch
new file mode 100644
index 000000000000..7b8a57da37a7
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-226.4-glibc.patch
@@ -0,0 +1,34 @@
+commit 27d13af71c3af6b2f9b60556d2c046dbb6e36e23
+Author: Mike Frysinger <vapier@gentoo.org>
+Date: Mon Mar 14 17:44:49 2016 -0400
+
+ include sys/sysmacros.h in more places
+
+ Since glibc is moving away from implicitly including sys/sysmacros.h
+ all the time via sys/types.h, include the header directly in more
+ places. This seems to cover most makedev/major/minor usage.
+
+diff --git a/src/basic/macro.h b/src/basic/macro.h
+index c34441d75..b36a95675 100644
+--- a/src/basic/macro.h
++++ b/src/basic/macro.h
+@@ -23,6 +23,7 @@
+ #include <inttypes.h>
+ #include <stdbool.h>
+ #include <sys/param.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+ #define _printf_(a,b) __attribute__ ((format (printf, a, b)))
+diff --git a/src/basic/util.h b/src/basic/util.h
+index e095254b5..286db0515 100644
+--- a/src/basic/util.h
++++ b/src/basic/util.h
+@@ -36,6 +36,7 @@
+ #include <mntent.h>
+ #include <sys/inotify.h>
+ #include <sys/statfs.h>
++#include <sys/sysmacros.h>
+
+ #include "macro.h"
+ #include "missing.h"