summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-13 22:44:50 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-13 22:49:44 -0400
commitd77602c4eccd120b2d9427d1d1adaad056dd6dd7 (patch)
treeeb8e6d3b8acf0293a9dd827c898461e98c7af400 /sys-auth/google-authenticator
parentwww-client/chromium: Check for python deps in host root (diff)
downloadgentoo-d77602c4eccd120b2d9427d1d1adaad056dd6dd7.tar.gz
gentoo-d77602c4eccd120b2d9427d1d1adaad056dd6dd7.tar.bz2
gentoo-d77602c4eccd120b2d9427d1d1adaad056dd6dd7.zip
sys-auth/google-authenticator: initial package #419177
Diffstat (limited to 'sys-auth/google-authenticator')
-rw-r--r--sys-auth/google-authenticator/Manifest1
-rw-r--r--sys-auth/google-authenticator/google-authenticator-1.01_pre20160307231538.ebuild72
-rw-r--r--sys-auth/google-authenticator/google-authenticator-9999.ebuild72
-rw-r--r--sys-auth/google-authenticator/metadata.xml10
4 files changed, 155 insertions, 0 deletions
diff --git a/sys-auth/google-authenticator/Manifest b/sys-auth/google-authenticator/Manifest
new file mode 100644
index 000000000000..ddc10ac8ae5c
--- /dev/null
+++ b/sys-auth/google-authenticator/Manifest
@@ -0,0 +1 @@
+DIST google-authenticator-1.01_pre20160307231538.tar.xz 255316 SHA256 41bdc47278903bc33e87c8b4da6f9fe5b526a2f780790d4f83bb67634f3f53b0 SHA512 cee3898b7afec54079968ff0690f076b78512b0b2c982ef5bedb2d6c5850b103c80191caa4b172069a83eb4d15ea4fce5b3f5eefdb36aa0426d985ba29736108 WHIRLPOOL 90e6439c632ccf4c791d988304b2e1cb7753f03ec03678b7f83946bdefc2bf1ca6d81538c484bc73561060fc7a7d80518845e13c49f6b5d943233e0123b2a1c8
diff --git a/sys-auth/google-authenticator/google-authenticator-1.01_pre20160307231538.ebuild b/sys-auth/google-authenticator/google-authenticator-1.01_pre20160307231538.ebuild
new file mode 100644
index 000000000000..d1c640ac25fe
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-1.01_pre20160307231538.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/google/${PN}.git"
+ inherit git-r3 autotools
+ S="${WORKDIR}/${P}/libpam"
+else
+ MY_P=${P%_pre*}
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ # Avoid building demos/tests all the time.
+ sed -i '/^noinst_PROGRAMS/s:^noinst:check:' configure.ac || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # We might want to use getpam_mod_dir from pam eclass,
+ # but the build already appends "/security" for us.
+ econf \
+ --docdir="\$(datarootdir)/doc/${PF}" \
+ --htmldir='$(docdir)/html' \
+ --libdir="/$(get_libdir)"
+}
+
+src_compile() {
+ default
+
+ if [[ ${PV} == "9999" ]] ; then
+ local stamp=$(date --date="$(git log -n1 --pretty=format:%ci master)" -u "+%Y%m%d%H%M%S")
+ emake dist
+
+ local otar=$(echo ${PN}-*.tar.gz)
+ local ntar="${otar%.tar.gz}_pre${stamp}.tar.xz"
+ zcat "${otar}" | xz > "${ntar}"
+ fi
+}
+
+src_install() {
+ default
+ # Punt the pam module libtool archive.
+ find "${ED}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}
diff --git a/sys-auth/google-authenticator/google-authenticator-9999.ebuild b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
new file mode 100644
index 000000000000..d1c640ac25fe
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/google/${PN}.git"
+ inherit git-r3 autotools
+ S="${WORKDIR}/${P}/libpam"
+else
+ MY_P=${P%_pre*}
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ # Avoid building demos/tests all the time.
+ sed -i '/^noinst_PROGRAMS/s:^noinst:check:' configure.ac || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # We might want to use getpam_mod_dir from pam eclass,
+ # but the build already appends "/security" for us.
+ econf \
+ --docdir="\$(datarootdir)/doc/${PF}" \
+ --htmldir='$(docdir)/html' \
+ --libdir="/$(get_libdir)"
+}
+
+src_compile() {
+ default
+
+ if [[ ${PV} == "9999" ]] ; then
+ local stamp=$(date --date="$(git log -n1 --pretty=format:%ci master)" -u "+%Y%m%d%H%M%S")
+ emake dist
+
+ local otar=$(echo ${PN}-*.tar.gz)
+ local ntar="${otar%.tar.gz}_pre${stamp}.tar.xz"
+ zcat "${otar}" | xz > "${ntar}"
+ fi
+}
+
+src_install() {
+ default
+ # Punt the pam module libtool archive.
+ find "${ED}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}
diff --git a/sys-auth/google-authenticator/metadata.xml b/sys-auth/google-authenticator/metadata.xml
new file mode 100644
index 000000000000..a7e93ea39af7
--- /dev/null
+++ b/sys-auth/google-authenticator/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>vapier@gentoo.org</email>
+</maintainer>
+<upstream>
+ <remote-id type="github">google/google-authenticator</remote-id>
+</upstream>
+</pkgmetadata>