summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:05 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:05 +0100
commitd851cb8e391541174ebfd67fbda4bdbeaf17aa81 (patch)
treeb19df51c213c6179688cbf860884ed38ce3207b2 /sys-auth/libnss-cache
parentsys-auth/fprint_demo: Port to EAPI 6 (diff)
downloadgentoo-d851cb8e391541174ebfd67fbda4bdbeaf17aa81.tar.gz
gentoo-d851cb8e391541174ebfd67fbda4bdbeaf17aa81.tar.bz2
gentoo-d851cb8e391541174ebfd67fbda4bdbeaf17aa81.zip
sys-auth/libnss-cache: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-auth/libnss-cache')
-rw-r--r--sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
index 0c1a0b837148..0ad34429a489 100644
--- a/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
+++ b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
-inherit eutils multilib toolchain-funcs
+inherit multilib-minimal toolchain-funcs
DESCRIPTION="libnss-cache is a library that serves nss lookups"
HOMEPAGE="https://github.com/google/nsscache"
@@ -12,23 +12,22 @@ SRC_URI="https://nsscache.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="multilib"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.1-make.patch
+ "${FILESDIR}"/${PN}-0.10-fix-shadow-test.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10.1-make.patch
- epatch "${FILESDIR}"/${PN}-0.10-fix-shadow-test.patch
+ default
+ multilib_copy_sources
}
-src_compile() {
- emake CC="$(tc-getCC)" nss_cache || die
- if use multilib && has_multilib_profile; then
- emake CC="$(tc-getCC)" nss_cache32 || die
- fi
+multilib_src_compile() {
+ emake CC="$(tc-getCC)" nss_cache
}
-src_install() {
- emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die
- if use multilib && has_multilib_profile; then
- emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install32 || die
- fi
+multilib_src_install() {
+ emake DESTDIR="${ED}" LIBDIR="${ED%/}/usr/$(get_libdir)" install
}