summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-05-29 20:50:25 +0200
committerAmy Winston <amynka@gentoo.org>2016-05-29 20:57:29 +0200
commit75e23df8c331b7498d1f27a82bf0d048f627bb3d (patch)
tree2ddd910c1122d949f1a2d8c32134e8d8db676740 /sys-auth/nss-mdns/nss-mdns-0.10-r3.ebuild
parentx11-drivers/xf86-video-openchrome: Version bump (diff)
downloadgentoo-75e23df8c331b7498d1f27a82bf0d048f627bb3d.tar.gz
gentoo-75e23df8c331b7498d1f27a82bf0d048f627bb3d.tar.bz2
gentoo-75e23df8c331b7498d1f27a82bf0d048f627bb3d.zip
sys-auth/nss-mdns: revbump, add ipv6 patch bug #584286
Package-Manager: portage-2.2.28 RepoMan-Options: --force
Diffstat (limited to 'sys-auth/nss-mdns/nss-mdns-0.10-r3.ebuild')
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.10-r3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-auth/nss-mdns/nss-mdns-0.10-r3.ebuild b/sys-auth/nss-mdns/nss-mdns-0.10-r3.ebuild
new file mode 100644
index 000000000000..3be4d71072f3
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.10-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="http://0pointer.de/lennart/projects/nss-mdns/"
+SRC_URI="http://0pointer.de/lennart/projects/nss-mdns/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~mips ppc x86"
+IUSE="search-domains"
+
+RDEPEND=">=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r7
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.10-avahi-socket.patch \
+ "${FILESDIR}"/${PN}-0.10-ipv6.patch
+ epatch_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable search-domains) \
+ --enable-avahi
+}
+
+multilib_src_install_all() {
+ dodoc README
+
+ insinto /etc
+ doins "${FILESDIR}"/mdns.allow
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You must modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns. Keep in mind that mdns will be slower if there are no"
+ ewarn "IPv6 addresses published via mDNS on the network. There are also"
+ ewarn "minimal (mdns?_minimal) libraries which only lookup .local hosts"
+ ewarn "and 169.254.x.x addresses."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf"
+ ewarn "An example line looks like:"
+ ewarn "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4"
+ ewarn
+ ewarn "If you want to perform mDNS lookups for domains other than the ones"
+ ewarn "ending in .local, add them to /etc/mdns.allow"
+ ewarn
+}