summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2021-03-06 00:13:26 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2021-03-06 01:03:59 -0500
commit540d9e57de2084bce17d23ae67c0b27307a67b6b (patch)
treeda267ce383ca3188a65ae04e93f65db6fafc22e4 /sys-auth/pam_u2f
parentsys-apps/rng-tools: fix the v6.11 bump (diff)
downloadgentoo-540d9e57de2084bce17d23ae67c0b27307a67b6b.tar.gz
gentoo-540d9e57de2084bce17d23ae67c0b27307a67b6b.tar.bz2
gentoo-540d9e57de2084bce17d23ae67c0b27307a67b6b.zip
sys-auth/pam_u2f: backport a patch to fix a build failure
There is a missing limits.h include but there are no new releases that includes the fix. Backport it. Closes: https://bugs.gentoo.org/751742 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'sys-auth/pam_u2f')
-rw-r--r--sys-auth/pam_u2f/files/pam_u2f-1.1.0-include-limits_h.patch41
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild7
2 files changed, 46 insertions, 2 deletions
diff --git a/sys-auth/pam_u2f/files/pam_u2f-1.1.0-include-limits_h.patch b/sys-auth/pam_u2f/files/pam_u2f-1.1.0-include-limits_h.patch
new file mode 100644
index 000000000000..edb959c7469d
--- /dev/null
+++ b/sys-auth/pam_u2f/files/pam_u2f-1.1.0-include-limits_h.patch
@@ -0,0 +1,41 @@
+From d46b5ed35017b089c30dd21305ac2147fcfc24f0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
+ <congdanhqx@gmail.com>
+Date: Fri, 16 Oct 2020 06:49:08 +0700
+Subject: [PATCH] b64,util: always include limits.h
+
+UCHAR_MAX and INT_MAX are defined within limits.h
+
+Current codebase failed to be built in Linux with musl libc due to
+missing this inclusion.
+
+Fix it.
+---
+ b64.c | 1 +
+ util.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/b64.c b/b64.c
+index 0649c1e..7788089 100644
+--- a/b64.c
++++ b/b64.c
+@@ -4,6 +4,7 @@
+
+ #include <openssl/bio.h>
+ #include <openssl/evp.h>
++#include <limits.h>
+ #include <stdint.h>
+ #include <string.h>
+
+diff --git a/util.c b/util.c
+index fdae095..3ea1bd2 100644
+--- a/util.c
++++ b/util.c
+@@ -9,6 +9,7 @@
+ #include <openssl/ec.h>
+ #include <openssl/obj_mac.h>
+
++#include <limits.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
diff --git a/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild b/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild
index 6d719d8985b6..eeb67dd08529 100644
--- a/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild
+++ b/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,10 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch"
+ "${FILESDIR}/${PN}-1.1.0-include-limits_h.patch"
+)
src_prepare() {
default