summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2016-06-23 20:50:56 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-28 17:38:44 -0400
commitd629f9fe9e99dc983188295b2d4be2ed7eeff494 (patch)
treefaa21f6b88ebfd5a7d4a2b6b9024a0d595b31b6b /sys-auth/pam_u2f
parentapp-crypt/libu2f-server: initial commit of U2F server library in C (diff)
downloadgentoo-d629f9fe9e99dc983188295b2d4be2ed7eeff494.tar.gz
gentoo-d629f9fe9e99dc983188295b2d4be2ed7eeff494.tar.bz2
gentoo-d629f9fe9e99dc983188295b2d4be2ed7eeff494.zip
sys-auth/pam_u2f: initial commit of U2F PAM module
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-auth/pam_u2f')
-rw-r--r--sys-auth/pam_u2f/Manifest1
-rw-r--r--sys-auth/pam_u2f/files/pam_u2f-1.0.2-fix-Makefile.patch13
-rw-r--r--sys-auth/pam_u2f/metadata.xml22
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild36
4 files changed, 72 insertions, 0 deletions
diff --git a/sys-auth/pam_u2f/Manifest b/sys-auth/pam_u2f/Manifest
new file mode 100644
index 000000000000..7af83b3eaa11
--- /dev/null
+++ b/sys-auth/pam_u2f/Manifest
@@ -0,0 +1 @@
+DIST pam_u2f-1.0.4.tar.gz 349114 SHA256 71542e4568e6d2acaa50810a93c67297ba402f960da1ebb621413bd31f0732a1 SHA512 324d1a1172eae567372f95971d9ee6bb237b47758b89c083f3cfb11275c4b0c22c4cf02a51380451f88d372dd6aaa415bdb671a43a7444062fbf8f50b658f087 WHIRLPOOL a4aeb74cb551d2c22de7cd1ab5cddf1ccff7d5d660017b0569c83478f33902dd8641325fef1f76033b7df2c4919c0def892208e1451a673f0c21b518f66dcd83
diff --git a/sys-auth/pam_u2f/files/pam_u2f-1.0.2-fix-Makefile.patch b/sys-auth/pam_u2f/files/pam_u2f-1.0.2-fix-Makefile.patch
new file mode 100644
index 000000000000..a83597602d45
--- /dev/null
+++ b/sys-auth/pam_u2f/files/pam_u2f-1.0.2-fix-Makefile.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -34,8 +34,8 @@
+ # Release
+
+ install-exec-hook:
+- rm -f $(PAMDIR)/pam_u2f.la
+- chmod -f 644 $(PAMDIR)/pam_u2f.so || true
++ rm -f $(DESTDIR)/$(PAMDIR)/pam_u2f.la
++ chmod -f 644 $(DESTDIR)/$(PAMDIR)/pam_u2f.so || true
+
+ indent:
+ indent -kr -nut -i2 *.c *.h pamu2fcfg/*.c pamu2fcfg/*.h
diff --git a/sys-auth/pam_u2f/metadata.xml b/sys-auth/pam_u2f/metadata.xml
new file mode 100644
index 000000000000..11ec7f2c19e3
--- /dev/null
+++ b/sys-auth/pam_u2f/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>shirk+gentoo@bitspin.org</email>
+ <name>René Köcher</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <use>
+ <flag name="debug">
+ Enable debug messages using the pam logging macros.
+ (Note: these will be visible on stdout for terminal logins).
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Yubico/pam-u2f</remote-id>
+ <bugs-to>https://github.com/Yubico/pam-u2f/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild b/sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild
new file mode 100644
index 000000000000..16a5741b650c
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/pam-u2f"
+SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/libu2f-host
+ app-crypt/libu2f-server
+ virtual/pam"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch" )
+
+src_prepare() {
+ default
+ use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pam-dir=$(getpam_mod_dir)
+}