summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-27 21:28:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-27 21:58:24 +0200
commit62eb14adde104adbfc5c6c524bba6d274d26f134 (patch)
tree5690964b7631d92013a49b3e410b9ed030ba9634 /sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
parentmedia-libs/phonon-vlc: Drop 0.10.3 (diff)
downloadgentoo-62eb14adde104adbfc5c6c524bba6d274d26f134.tar.gz
gentoo-62eb14adde104adbfc5c6c524bba6d274d26f134.tar.bz2
gentoo-62eb14adde104adbfc5c6c524bba6d274d26f134.zip
sys-auth/polkit-qt: 0.113 version bump
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild')
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
new file mode 100644
index 000000000000..7191cd244da6
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN}-1"
+MY_P="${MY_PN}-${PV}"
+inherit cmake-utils
+
+DESCRIPTION="Qt wrapper around polkit-1 client libraries"
+HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
+SRC_URI="mirror://kde/stable/${MY_PN}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ )
+
+ cmake-utils_src_configure
+}