summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/tfm-fingerprint
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/tfm-fingerprint')
-rw-r--r--sys-auth/tfm-fingerprint/Manifest1
-rw-r--r--sys-auth/tfm-fingerprint/files/tfmessbsp.cfg4
-rw-r--r--sys-auth/tfm-fingerprint/metadata.xml8
-rw-r--r--sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild47
4 files changed, 60 insertions, 0 deletions
diff --git a/sys-auth/tfm-fingerprint/Manifest b/sys-auth/tfm-fingerprint/Manifest
new file mode 100644
index 000000000000..0ecfd5089f13
--- /dev/null
+++ b/sys-auth/tfm-fingerprint/Manifest
@@ -0,0 +1 @@
+DIST TFMESS_BSP_LIN_1.0.zip 922652 SHA256 9ca1dcb059e326d4c760c8f8ceb4df5970ab9897062487453a2ac5e9e7058368 SHA512 dd0a965eea21b6d04178b39847246187aaca32c297a7fc0a45dc8dfe663f4951627223760a322d0a8beb50c2bc8485db63c7e1e6dfa49612c15427fd0bace3ee WHIRLPOOL 014aef94ee6b59ed12d9ff8861dff408aa6a63bdad0da27c4e2ee84e0e613c352909816907065f9294deddf0349f0aed69d059b8ca8d24380b6600f5b9b807cb
diff --git a/sys-auth/tfm-fingerprint/files/tfmessbsp.cfg b/sys-auth/tfm-fingerprint/files/tfmessbsp.cfg
new file mode 100644
index 000000000000..f7d93eb20519
--- /dev/null
+++ b/sys-auth/tfm-fingerprint/files/tfmessbsp.cfg
@@ -0,0 +1,4 @@
+#hide-capture-success="0"
+hide-capture-success="0"
+#security-level="3"
+security-level="3"
diff --git a/sys-auth/tfm-fingerprint/metadata.xml b/sys-auth/tfm-fingerprint/metadata.xml
new file mode 100644
index 000000000000..a2e51d46d661
--- /dev/null
+++ b/sys-auth/tfm-fingerprint/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild b/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
new file mode 100644
index 000000000000..3bdfb000e817
--- /dev/null
+++ b/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib
+
+DESCRIPTION="TouchChip TFM/ESS FingerPrint BSP"
+HOMEPAGE="http://www.upek.com/support/dl_linux_bsp.asp"
+SRC_URI="http://www.upek.com/support/download/TFMESS_BSP_LIN_${PV}.zip"
+
+LICENSE="UPEK-SDK-EULA"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+RDEPEND="sys-auth/bioapi"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+QA_TEXTRELS="usr/lib/libtfmessbsp.so"
+QA_PRESTRIPPED="usr/lib/libtfmessbsp.so"
+
+src_install() {
+ # this is a binary blob, so it probably shouldnt live in /usr/lib
+ dolib.so libtfmessbsp.so || die
+ insinto /etc
+ doins "${FILESDIR}"/tfmessbsp.cfg || die
+}
+
+doit_with_ewarn() {
+ "$@" || ewarn "FAILURE: $*"
+}
+
+pkg_postinst() {
+ doit_with_ewarn mod_install -fi /usr/$(get_libdir)/libtfmessbsp.so
+
+ elog "Note: You have to be in the group usb to access the fingerprint device."
+}
+
+pkg_postrm() {
+ # only do this if uninstalling
+ if ! has_version ${CATEGORY}/${PN} ; then
+ doit_with_ewarn mod_install -fu libtfmessbsp.so
+ fi
+}