summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-14 12:17:49 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-14 12:18:37 +0100
commite13b5501105ae03e2a258bd1d6f1b0e172da124c (patch)
tree9e634d55d83ea96aa3fa8db8da91f18d30591dfc /sys-auth/yubico-piv-tool
parentdev-util/cmake: Mark ~hppa (bug #599668). (diff)
downloadgentoo-e13b5501105ae03e2a258bd1d6f1b0e172da124c.tar.gz
gentoo-e13b5501105ae03e2a258bd1d6f1b0e172da124c.tar.bz2
gentoo-e13b5501105ae03e2a258bd1d6f1b0e172da124c.zip
sys-auth/yubico-piv-tool: Initial version
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-auth/yubico-piv-tool')
-rw-r--r--sys-auth/yubico-piv-tool/Manifest1
-rw-r--r--sys-auth/yubico-piv-tool/files/yubico-piv-tool-1.4.2-help2man-fix.patch23
-rw-r--r--sys-auth/yubico-piv-tool/metadata.xml11
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-1.4.2.ebuild32
4 files changed, 67 insertions, 0 deletions
diff --git a/sys-auth/yubico-piv-tool/Manifest b/sys-auth/yubico-piv-tool/Manifest
new file mode 100644
index 000000000000..b2ec4cb9c219
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/Manifest
@@ -0,0 +1 @@
+DIST yubico-piv-tool-1.4.2.tar.gz 113783 SHA256 814609e0ee2cc3be6f1908e1a62c6f6e280c8e15991ecea1c0afce70b48b6a8a SHA512 f2fd80a8d6faddf750d648c4777fb4d7f484a243e6d74c18fa0effc56469ded8e03f9c3437494c3e2d2cfba6397b6bcdec5d1286900b2908f21e1f0ccaeb59eb WHIRLPOOL 12516ac66fbe74202a76bb1dee4630792372974cea57f83c188167643acd4abf9855794b769fe7c9878f8d964cf5d17f98e7906d09101679133379a1e3bde7a5
diff --git a/sys-auth/yubico-piv-tool/files/yubico-piv-tool-1.4.2-help2man-fix.patch b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-1.4.2-help2man-fix.patch
new file mode 100644
index 000000000000..46513315219a
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-1.4.2-help2man-fix.patch
@@ -0,0 +1,23 @@
+From 8bdf7378d6ada57204f93684a488368bbae11858 Mon Sep 17 00:00:00 2001
+From: Klas Lindfors <klas@yubico.com>
+Date: Mon, 12 Sep 2016 09:54:04 +0200
+Subject: [PATCH] fixup dependencies for yubico-piv-tool.1
+
+should now support parallel builds
+---
+ tool/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tool/Makefile.am b/tool/Makefile.am
+index 6100da7..4a1657b 100644
+--- a/tool/Makefile.am
++++ b/tool/Makefile.am
+@@ -54,7 +54,7 @@ MAINTAINERCLEANFILES = $(BUILT_SOURCES)
+ dist_man_MANS = yubico-piv-tool.1
+ MAINTAINERCLEANFILES += $(dist_man_MANS)
+
+-yubico-piv-tool.1: $(yubico_piv_tool_SOURCES) $(libpiv_cmd_la_SOURCES)
++yubico-piv-tool.1: $(yubico_piv_tool_SOURCES) $(libpiv_cmd_la_SOURCES) $(top_srcdir)/configure.ac | $(builddir)/yubico-piv-tool$(EXEEXT)
+ $(HELP2MAN) --no-info \
+ --name="Yubico PIV tool" \
+ --include=$(srcdir)/yubico-piv-tool.h2m \
diff --git a/sys-auth/yubico-piv-tool/metadata.xml b/sys-auth/yubico-piv-tool/metadata.xml
new file mode 100644
index 000000000000..1b855a968651
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubico-piv-tool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-1.4.2.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.4.2.ebuild
new file mode 100644
index 000000000000..eef3429304a0
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Command line tool for the YubiKey PIV application"
+SRC_URI="https://github.com/Yubico/yubico-piv-tool/archive/yubico-piv-tool-${PV}.tar.gz"
+HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
+
+LICENSE="BSD-2"
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/openssl:0=
+ sys-apps/pcsc-lite"
+DEPEND="dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=( "${FILESDIR}"/${P}-help2man-fix.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}