summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-05-10 15:18:21 +0800
committerJason Zaman <perfinion@gentoo.org>2017-05-10 15:18:56 +0800
commit2e87a11150cdaf7c50f2036aa1817475764c7495 (patch)
tree08c99532638988d4ea89669b451f6c74783fce4d /sys-auth
parentsys-auth/consolekit: bump to 1.1.1 (diff)
downloadgentoo-2e87a11150cdaf7c50f2036aa1817475764c7495.tar.gz
gentoo-2e87a11150cdaf7c50f2036aa1817475764c7495.tar.bz2
gentoo-2e87a11150cdaf7c50f2036aa1817475764c7495.zip
sys-auth/consolekit: update live ebuild
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/consolekit-9999.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/sys-auth/consolekit/consolekit-9999.ebuild b/sys-auth/consolekit/consolekit-9999.ebuild
index e8c827527b64..1053ee4ea8ac 100644
--- a/sys-auth/consolekit/consolekit-9999.ebuild
+++ b/sys-auth/consolekit/consolekit-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="acl cgroups debug doc kernel_linux pam pm-utils policykit selinux test"
+IUSE="acl cgroups debug doc evdev kernel_linux pam pm-utils policykit selinux test udev"
COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
>=sys-devel/gettext-0.19
@@ -29,8 +29,14 @@ COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
app-admin/cgmanager
>=sys-libs/libnih-1.0.2[dbus]
)
+ evdev? ( dev-libs/libevdev:= )
+ udev? (
+ virtual/libudev
+ x11-libs/libdrm:=
+ )
pam? ( virtual/pam )
- policykit? ( >=sys-auth/polkit-0.110 )"
+ policykit? ( >=sys-auth/polkit-0.110 )
+ selinux? ( sys-libs/libselinux )"
# pm-utils: bug 557432
RDEPEND="${COMMON_DEPEND}
kernel_linux? ( sys-apps/coreutils[acl?] )
@@ -61,8 +67,8 @@ src_prepare() {
sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
default
- elibtoolize # bug 593314
eautoreconf
+ #elibtoolize # bug 593314
}
src_configure() {
@@ -75,8 +81,11 @@ src_configure() {
$(use_enable test docbook-docs) \
$(use_enable debug) \
$(use_enable policykit polkit) \
+ $(use_enable evdev libevdev) \
$(use_enable acl udev-acl) \
$(use_enable cgroups) \
+ $(use_enable selinux) \
+ $(use_enable udev libudev) \
$(use_enable test tests) \
--with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
--with-pam-module-dir="$(getpam_mod_dir)" \