summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-04-17 13:52:48 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-04-17 16:11:28 +0200
commit459127cd575a4118a0cedb71d0dd3271c395a8e7 (patch)
treea6f0b54787bf47733997b3dbb6b58c79996115f4 /sys-auth
parentsys-apps/cpuid: add 20240409 (diff)
downloadgentoo-459127cd575a4118a0cedb71d0dd3271c395a8e7.tar.gz
gentoo-459127cd575a4118a0cedb71d0dd3271c395a8e7.tar.bz2
gentoo-459127cd575a4118a0cedb71d0dd3271c395a8e7.zip
sys-auth/AusweisApp: add 2.1.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp/AusweisApp-2.1.1.ebuild47
-rw-r--r--sys-auth/AusweisApp/Manifest1
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp/AusweisApp-2.1.1.ebuild b/sys-auth/AusweisApp/AusweisApp-2.1.1.ebuild
new file mode 100644
index 000000000000..d86746427953
--- /dev/null
+++ b/sys-auth/AusweisApp/AusweisApp-2.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-qt/qtshadertools:6
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtbase:6[concurrent,network,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ dev-qt/qtwebsockets:6[qml]
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp/Manifest b/sys-auth/AusweisApp/Manifest
index 7f83ceda3b97..11ba65d222ef 100644
--- a/sys-auth/AusweisApp/Manifest
+++ b/sys-auth/AusweisApp/Manifest
@@ -1 +1,2 @@
DIST AusweisApp-2.1.0.tar.gz 5876657 BLAKE2B 54c8676dda53a667104f8edf8fc70fc4ca736b1207bea0ce2a5fc0a628216ce4f001adac03308fceccbb8ad834d171f364ac6b4e948ada26d6983ede827fd10e SHA512 a7186bdfe3ebd6779588dc6fa219fcc2f60d36c62a8b9956bbdc86e4962120e46b39266e7207cf0de4d84f9212d1616bbec9f8901cb0a112bcfcae1684f3ff75
+DIST AusweisApp-2.1.1.tar.gz 5878477 BLAKE2B c2948b51a7a04e36aa5bdfb805cd4ecb565fff5c67e040c0159adb4c10fd7e956e1968f5e12df48057bcd5c09dfd91d79aee781fb2a26319a0c2a3ef1a131d85 SHA512 124e92238b81ae2fd7865bc018ce64723a4d237e214b5166385fe191ae5365b5c9e260ecae8d249355d8dc61df08beea0988a622f6712132e7b164cb7f832674