summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-07 14:44:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-07 14:44:58 +0200
commit5acd1190fb098a9e938cc8daf3c55d31083e4dbb (patch)
treebe2205e0cb63307653875b81785b6802cb22fdcb /sys-auth
parentapp-doc/single-unix-specification: Drop old (diff)
downloadgentoo-5acd1190fb098a9e938cc8daf3c55d31083e4dbb.tar.gz
gentoo-5acd1190fb098a9e938cc8daf3c55d31083e4dbb.tar.bz2
gentoo-5acd1190fb098a9e938cc8daf3c55d31083e4dbb.zip
sys-auth/elogind: Fix build with >=meson-0.48
Thanks-to: Boris Vingradov <no111u3@gmail.com> Closes: https://bugs.gentoo.org/667948 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/elogind/elogind-238.1.ebuild7
-rw-r--r--sys-auth/elogind/files/elogind-238.1-meson-0.48.patch46
2 files changed, 51 insertions, 2 deletions
diff --git a/sys-auth/elogind/elogind-238.1.ebuild b/sys-auth/elogind/elogind-238.1.ebuild
index cc148ee6f8da..176b4b39bba9 100644
--- a/sys-auth/elogind/elogind-238.1.ebuild
+++ b/sys-auth/elogind/elogind-238.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,7 +41,10 @@ PDEPEND="
DOCS=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
-PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-docs.patch"
+ "${FILESDIR}/${P}-meson-0.48.patch"
+)
pkg_setup() {
local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
diff --git a/sys-auth/elogind/files/elogind-238.1-meson-0.48.patch b/sys-auth/elogind/files/elogind-238.1-meson-0.48.patch
new file mode 100644
index 000000000000..ea4ce0f8f933
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-238.1-meson-0.48.patch
@@ -0,0 +1,46 @@
+From 63c4b947c4fddbefd8d35acf6dffdaf34d6077ee Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Sun, 19 Aug 2018 19:11:30 +0200
+Subject: [PATCH] meson: rename -Ddebug to -Ddebug-extra
+
+Meson added -Doptimization and -Ddebug options, which obviously causes
+a conflict with our -Ddebug options. Let's rename it.
+
+Fixes #76.
+---
+ meson.build | 2 +-
+ meson_options.txt | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 05a257d1f..117af9e5e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -936,7 +936,7 @@ conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
+ # substs.set('DEBUGTTY', get_option('debug-tty'))
+ #endif // 0
+
+-debug = get_option('debug')
++debug = get_option('debug-extra')
+ enable_debug_hashmap = false
+ enable_debug_mmap_cache = false
+ #if 1 /// additional elogind debug mode
+diff --git a/meson_options.txt b/meson_options.txt
+index 84100b629..f12b542e5 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -77,12 +77,12 @@ option('kexec-path', type : 'string', description : 'path to kexec')
+ # description : 'path to debug shell binary')
+ # option('debug-tty', type : 'string', value : '/dev/tty9',
+ # description : 'specify the tty device for debug shell')
+-# option('debug', type : 'string',
++# option('debug-extra', type : 'string',
+ # description : 'enable extra debugging (hashmap,mmap-cache)')
+ # option('memory-accounting-default', type : 'boolean',
+ # description : 'enable MemoryAccounting= by default')
+ #else
+-option('debug', type : 'string',
++option('debug-extra', type : 'string',
+ description : 'enable extra debugging (elogind,hashmap,mmap-cache)')
+ #endif // 0
+ \ No newline at end of file