summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-15 16:07:52 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-15 16:07:52 +0200
commit6bda8f8faebd98ed5c16316ac051a34d7874c940 (patch)
tree08111f27a3122bd5d84ffc2bff0566c229ee4b01 /sys-auth
parentdev-ml/ppxlib: Add RDEPEND dev-ml/findlib:= (diff)
downloadgentoo-6bda8f8faebd98ed5c16316ac051a34d7874c940.tar.gz
gentoo-6bda8f8faebd98ed5c16316ac051a34d7874c940.tar.bz2
gentoo-6bda8f8faebd98ed5c16316ac051a34d7874c940.zip
sys-auth/yubico-piv-tool: remove old
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1-r1.ebuild52
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild42
2 files changed, 0 insertions, 94 deletions
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1-r1.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1-r1.ebuild
deleted file mode 100644
index 07beb0c0d0d4..000000000000
--- a/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Command line tool for the YubiKey PIV application"
-SRC_URI="https://github.com/Yubico/yubico-piv-tool/archive/yubico-piv-tool-${PV}.tar.gz"
-HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
-
-LICENSE="BSD-2"
-SLOT="0/1"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/openssl:0=[-bindist]
- sys-apps/pcsc-lite
-"
-DEPEND="${RDEPEND}
- dev-util/gengetopt
- sys-apps/help2man
- virtual/pkgconfig
- test? ( dev-libs/check )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.1-install-man-page.patch
- "${FILESDIR}"/${PN}-2.1.1-tests-optional.patch
- "${FILESDIR}"/${PN}-2.1.1-ykcs11-threads.patch
-)
-
-S="${WORKDIR}/${PN}-${P}"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_STATIC_LIB=OFF
- -DBUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- echo "module: ${EPREFIX}/usr/$(get_libdir)/libykcs11.so" > ${PN}.module \
- || die "Failed to generate p11-kit module configuration"
- insinto /usr/share/p11-kit/modules
- doins ${PN}.module
-}
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild
deleted file mode 100644
index e250affc1b84..000000000000
--- a/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Command line tool for the YubiKey PIV application"
-SRC_URI="https://github.com/Yubico/yubico-piv-tool/archive/yubico-piv-tool-${PV}.tar.gz"
-HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
-
-LICENSE="BSD-2"
-SLOT="0/1"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/openssl:0=[-bindist]
- sys-apps/pcsc-lite
-"
-DEPEND="${RDEPEND}
- dev-util/gengetopt
- sys-apps/help2man
- virtual/pkgconfig
- test? ( dev-libs/check )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.1-install-man-page.patch
- "${FILESDIR}"/${PN}-2.1.1-tests-optional.patch
-)
-
-S="${WORKDIR}/${PN}-${P}"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_STATIC_LIB=OFF
- -DBUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}