summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-12-13 01:09:30 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-12-13 18:02:25 +0300
commit81fe8bc6eee3c5893336595cfa6b426d769290c9 (patch)
tree4050ec31ef18bf300becc4136f8031711c6b104b /sys-auth
parentdev-lang/swi-prolog: bump development version (diff)
downloadgentoo-81fe8bc6eee3c5893336595cfa6b426d769290c9.tar.gz
gentoo-81fe8bc6eee3c5893336595cfa6b426d769290c9.tar.bz2
gentoo-81fe8bc6eee3c5893336595cfa6b426d769290c9.zip
sys-auth/pam_dotfile: port to EAPI=7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_dotfile/pam_dotfile-0.7-r2.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-auth/pam_dotfile/pam_dotfile-0.7-r2.ebuild b/sys-auth/pam_dotfile/pam_dotfile-0.7-r2.ebuild
index 5ec0eed67259..335c08e47e4d 100644
--- a/sys-auth/pam_dotfile/pam_dotfile-0.7-r2.ebuild
+++ b/sys-auth/pam_dotfile/pam_dotfile-0.7-r2.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils pam autotools autotools-utils
+inherit autotools pam
MY_P="${P/_beta/beta}"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="pam module to allow password-storing in \$HOME/dotfiles"
HOMEPAGE="http://0pointer.de/lennart/projects/pam_dotfile/
@@ -18,14 +17,15 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="doc"
+BDEPEND="doc? ( www-client/lynx )"
RDEPEND="sys-libs/pam"
-DEPEND="${RDEPEND}
- doc? ( www-client/lynx )"
+DEPEND="${RDEPEND}"
-HTML_DOCS="doc"
+S="${WORKDIR}/${MY_P}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ default
+ eapply "${FILESDIR}"/${P}-gentoo.patch
eautoreconf
}
@@ -34,12 +34,12 @@ src_configure() {
$(use_enable doc lynx)
--with-pammoddir=$(getpam_mod_dir)
)
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
}
src_install() {
- autotools-utils_src_install
+ default
# kill the libtool archives
- rm -rf "${D}"/$(getpam_mod_dir)/*.la
+ rm -rf "${D}"/$(getpam_mod_dir)/*.la || die
}