summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-11-23 23:09:03 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-23 23:16:23 +0100
commitcff219fdc918fb056d1a52b1481729880193fcd6 (patch)
tree5e2cb4e3db8a56cc3b7522b19a1a17a041ad20df /sys-auth
parentsys-libs/pam: mask app-vim/pam-syntax for removal. (diff)
downloadgentoo-cff219fdc918fb056d1a52b1481729880193fcd6.tar.gz
gentoo-cff219fdc918fb056d1a52b1481729880193fcd6.tar.bz2
gentoo-cff219fdc918fb056d1a52b1481729880193fcd6.zip
sys-auth/openpam: mask app-vim/pam-syntax for removal.
Bug: https://bugs.gentoo.org/578278 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/openpam/openpam-20140912-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/openpam/openpam-20140912-r1.ebuild b/sys-auth/openpam/openpam-20140912-r1.ebuild
new file mode 100644
index 000000000000..9a8583315e19
--- /dev/null
+++ b/sys-auth/openpam/openpam-20140912-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit multilib autotools-multilib
+
+DESCRIPTION="Open source PAM library"
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="debug vim-syntax"
+
+RDEPEND="!sys-libs/pam"
+DEPEND="
+ sys-devel/make
+ dev-lang/perl"
+
+PDEPEND="
+ sys-auth/pambase
+ vim-syntax? ( app-vim/pam-syntax )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20130907-gentoo.patch"
+ "${FILESDIR}/${PN}-20130907-nbsd.patch"
+ "${FILESDIR}/${PN}-20130907-module-dir.patch"
+)
+
+DOCS=( CREDITS HISTORY RELNOTES README )
+
+src_prepare() {
+ sed -i -e 's:-Werror::' "${S}/configure.ac"
+
+ autotools-multilib_src_prepare
+}
+
+my_configure() {
+ local myeconfargs=(
+ --with-modules-dir=/$(get_libdir)/security
+ )
+ autotools-utils_src_configure
+}
+
+src_configure() {
+ multilib_parallel_foreach_abi my_configure
+}