summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-01-22 10:04:30 +0000
committerMarek Szuba <marecki@gentoo.org>2021-01-22 10:47:46 +0000
commite1b24aaf4a574a6c4b8b7feb641c42930a23d180 (patch)
treee2e91fd3c118989ebd5c17accecfb26e06fb68b7 /sys-auth
parentnet-misc/icaclient: create basic version info file (diff)
downloadgentoo-e1b24aaf4a574a6c4b8b7feb641c42930a23d180.tar.gz
gentoo-e1b24aaf4a574a6c4b8b7feb641c42930a23d180.tar.bz2
gentoo-e1b24aaf4a574a6c4b8b7feb641c42930a23d180.zip
sys-auth/solo-python: bump to 0.0.27
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/solo-python/Manifest1
-rw-r--r--sys-auth/solo-python/solo-python-0.0.27.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
index 8bbc1177b9e0..838e3bfdccd9 100644
--- a/sys-auth/solo-python/Manifest
+++ b/sys-auth/solo-python/Manifest
@@ -1 +1,2 @@
DIST solo-python-0.0.26.tar.gz 35251 BLAKE2B 76e515667220a8efdd16e159008eed8232721e0a8a1a1bffbc773cfa832b2f112d8dc229bf69dc4ccbee1d11b41d630a2d91e2383ebd19158d8c46ccf4f355de SHA512 f97da4a4ed3b0e0f4715407b179d8a8c1385076611fe8669cec6b514313d38dd14c6c22434b73e2c72f7456407a6c942b26b72cca7a56969cfbc630ee25aad85
+DIST solo-python-0.0.27.tar.gz 35657 BLAKE2B 747d8849ad4bdda7c0e4b079dce2d7162f07dad4784bb941242dd8ea759cccd763537cec2c7cd9ecf6f467c771729217648b72aa36292622f5fc3adb8a0c280c SHA512 50d564916e07a0c65a843bd2d0328a735ba71eadcfc893b13fac84a3e51822ed2bf80fc3f7662943a5635c6cd6b3ded8ba5b5a9ac2282c9f9bcdfe9de191e445
diff --git a/sys-auth/solo-python/solo-python-0.0.27.ebuild b/sys-auth/solo-python/solo-python-0.0.27.ebuild
new file mode 100644
index 000000000000..29ea8a9393ae
--- /dev/null
+++ b/sys-auth/solo-python/solo-python-0.0.27.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool and library for SoloKeys"
+HOMEPAGE="https://github.com/solokeys/solo-python"
+SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/click-7.0.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.8.1[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
+ # and in any case there is no advantage to using one once a specific version has been released.
+ sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
+ distutils-r1_src_prepare
+}