summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/btrace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/btrace')
-rw-r--r--sys-block/btrace/Manifest4
-rw-r--r--sys-block/btrace/btrace-1.0.0.ebuild45
-rw-r--r--sys-block/btrace/btrace-1.0.1-r1.ebuild46
-rw-r--r--sys-block/btrace/btrace-1.0.1.ebuild46
-rw-r--r--sys-block/btrace/btrace-1.0.3.ebuild46
-rw-r--r--sys-block/btrace/btrace-1.1.0.ebuild46
-rw-r--r--sys-block/btrace/files/btrace-1.0.0-parallel-make.patch20
-rw-r--r--sys-block/btrace/files/btrace-1.0.1-ldflags-parallel-make.patch91
-rw-r--r--sys-block/btrace/files/btrace-1.1.0-ldflags-parallel-make.patch105
-rw-r--r--sys-block/btrace/metadata.xml7
10 files changed, 456 insertions, 0 deletions
diff --git a/sys-block/btrace/Manifest b/sys-block/btrace/Manifest
new file mode 100644
index 000000000000..dd6b9df42272
--- /dev/null
+++ b/sys-block/btrace/Manifest
@@ -0,0 +1,4 @@
+DIST blktrace-1.0.0.tar.bz2 1592300 SHA256 fb220463f55aaa6ead931991e2f7f6ddae18faaf5bfa65fe42f502a27afa0abf
+DIST blktrace-1.0.1.tar.bz2 292208 SHA256 fdd1481a69f14b916f8d835203c1189ee3076d4a5ff88163b6e6b1f27b087f6d SHA512 7faac50dd04ccc0b782f9d2e8909161e42614a348792af736fac8924680ab9eff6d0db0dea9717a0a468577cc03f8bb1314f4d61cb0f0d92423c000fce89c172 WHIRLPOOL 74559960ae7fd6b0eecc9457221f5133f46bbf23e6e096bc96226c85cee49999ae9cf67a3e8bff66722dca7cd43afaf910ac47dfe1d850f83c63e0db6f0ea70d
+DIST blktrace-1.0.3.tar.bz2 359325 SHA256 221b66a6008a46bc41b8e455cfb1ba924849ce660ac7c7f9dff0fb64c07becb2 SHA512 f20a33b5309146304277a5f8a4c7f2c61e804b2caa5c62d00425ef26fcd1cd628521067b2502d05c368e10d2cd38a98c246030705ba358f835e8a6921444f9a5 WHIRLPOOL 3de4ef8db992e6b6e697b35ae6a2e47b36e5a9157bc6fafc8fc0de206ee15e3e8ceb4dc3bf70c9dfaae16567bbf4c6d8e81f38a3f1619d804b1a680cbfa1ac81
+DIST blktrace-1.1.0.tar.bz2 395445 SHA256 54a2faaa06dd52fd4a56a6aafa2a251990eb8dcf1832bb8c2fb1fc13a74a9295 SHA512 52ed3b66e1ec62c2204d44037d4d13218fd0229ae694493a21f1e83bfc8aeb029edc96b2be83f39cc3e79500abad56cd5a71c8c4e6dd836661777662f3628355 WHIRLPOOL b2777e248533fee8ffe3d92e0311d5797f12f57e188dce94b39e4531b58350ed600a64b50cae590455b52e92b8727c098b56f2c92e58a0567641123201ec9085
diff --git a/sys-block/btrace/btrace-1.0.0.ebuild b/sys-block/btrace/btrace-1.0.0.ebuild
new file mode 100644
index 000000000000..cd919e3ca031
--- /dev/null
+++ b/sys-block/btrace/btrace-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? ( virtual/latex-base app-text/dvipdfm )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_PN}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-1.0.0-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}
diff --git a/sys-block/btrace/btrace-1.0.1-r1.ebuild b/sys-block/btrace/btrace-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..5f8f5362a5a6
--- /dev/null
+++ b/sys-block/btrace/btrace-1.0.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? ( virtual/latex-base app-text/dvipdfm )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-ldflags-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}
diff --git a/sys-block/btrace/btrace-1.0.1.ebuild b/sys-block/btrace/btrace-1.0.1.ebuild
new file mode 100644
index 000000000000..a87e223f8097
--- /dev/null
+++ b/sys-block/btrace/btrace-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? ( virtual/latex-base app-text/dvipdfm )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_OPTS="-p1" epatch "${FILESDIR}"/${PN}-1.0.0-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}
diff --git a/sys-block/btrace/btrace-1.0.3.ebuild b/sys-block/btrace/btrace-1.0.3.ebuild
new file mode 100644
index 000000000000..9ce1119a4895
--- /dev/null
+++ b/sys-block/btrace/btrace-1.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? ( virtual/latex-base app-text/dvipdfm )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-ldflags-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}
diff --git a/sys-block/btrace/btrace-1.1.0.ebuild b/sys-block/btrace/btrace-1.1.0.ebuild
new file mode 100644
index 000000000000..27df22b5b8aa
--- /dev/null
+++ b/sys-block/btrace/btrace-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? ( virtual/latex-base app-text/dvipdfm )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.0-ldflags-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}
diff --git a/sys-block/btrace/files/btrace-1.0.0-parallel-make.patch b/sys-block/btrace/files/btrace-1.0.0-parallel-make.patch
new file mode 100644
index 000000000000..d3f42964c2b9
--- /dev/null
+++ b/sys-block/btrace/files/btrace-1.0.0-parallel-make.patch
@@ -0,0 +1,20 @@
+diff -Nuar blktrace.orig/Makefile blktrace/Makefile
+--- blktrace.orig/Makefile 2008-10-30 07:20:02.000000000 -0700
++++ blktrace/Makefile 2009-04-12 17:54:46.351588795 -0700
+@@ -10,13 +10,13 @@
+
+ all: $(ALL)
+
+-btt/btt:
++btt/btt: $(PROGS)
+ $(MAKE) -C btt
+
+-btreplay/btrecord:
++btreplay/btrecord: $(PROGS)
+ $(MAKE) -C btreplay
+
+-btreplay/btreplay:
++btreplay/btreplay: $(PROGS)
+ $(MAKE) -C btreplay
+
+ %.o: %.c
diff --git a/sys-block/btrace/files/btrace-1.0.1-ldflags-parallel-make.patch b/sys-block/btrace/files/btrace-1.0.1-ldflags-parallel-make.patch
new file mode 100644
index 000000000000..40c7d97d5dea
--- /dev/null
+++ b/sys-block/btrace/files/btrace-1.0.1-ldflags-parallel-make.patch
@@ -0,0 +1,91 @@
+diff -Nuar blktrace-1.0.1.orig/btreplay/Makefile blktrace-1.0.1/btreplay/Makefile
+--- blktrace-1.0.1.orig/btreplay/Makefile 2009-05-11 12:00:10.000000000 +0000
++++ blktrace-1.0.1/btreplay/Makefile 2011-02-03 03:01:41.161365886 +0000
+@@ -32,10 +32,10 @@
+ $(CC) $(CFLAGS) -c -o $*.o $<
+
+ btrecord: btrecord.o
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ btreplay: btreplay.o
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ depend:
+ @$(CC) -MM $(CFLAGS) *.c 1> .depend
+diff -Nuar blktrace-1.0.1.orig/btt/Makefile blktrace-1.0.1/btt/Makefile
+--- blktrace-1.0.1.orig/btt/Makefile 2009-05-11 12:00:10.000000000 +0000
++++ blktrace-1.0.1/btt/Makefile 2011-02-03 03:01:41.161365886 +0000
+@@ -38,7 +38,7 @@
+ $(CC) $(CFLAGS) -c -o $*.o $<
+
+ btt: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ ifneq ($(wildcard .depend),)
+ include .depend
+diff -Nuar blktrace-1.0.1.orig/Makefile blktrace-1.0.1/Makefile
+--- blktrace-1.0.1.orig/Makefile 2009-05-11 12:00:10.000000000 +0000
++++ blktrace-1.0.1/Makefile 2011-02-03 03:03:32.713725832 +0000
+@@ -4,38 +4,35 @@
+ PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
+ LIBS = -lpthread
+ SCRIPTS = btrace
++SUBDIRS = btreplay btt
+
+-ALL = $(PROGS) $(SCRIPTS) btt/btt btreplay/btrecord btreplay/btreplay \
++ALL = $(PROGS) $(SCRIPTS)
++INSTALL_ALL = $(ALL) btt/btt btreplay/btrecord btreplay/btreplay \
+ btt/bno_plot.py
+
+-all: $(ALL)
++all: $(ALL) $(SUBDIRS)
++.PHONY: $(SUBDIRS)
+
+-btt/btt:
+- $(MAKE) -C btt
+-
+-btreplay/btrecord:
+- $(MAKE) -C btreplay
+-
+-btreplay/btreplay:
+- $(MAKE) -C btreplay
++$(SUBDIRS): $(PROGS)
++ $(MAKE) -C $@
+
+ %.o: %.c
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ blkparse: blkparse.o blkparse_fmt.o rbtree.o act_mask.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blktrace: blktrace.o act_mask.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ verify_blkparse: verify_blkparse.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blkrawverify: blkrawverify.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blkiomon: blkiomon.o rbtree.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
+
+ $(PROGS): | depend
+
+@@ -81,7 +78,7 @@
+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man8
+- $(INSTALL) -m 755 $(ALL) $(DESTDIR)$(bindir)
++ $(INSTALL) -m 755 $(INSTALL_ALL) $(DESTDIR)$(bindir)
+ $(INSTALL) -m 644 doc/*.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 644 doc/*.8 $(DESTDIR)$(mandir)/man8
+
diff --git a/sys-block/btrace/files/btrace-1.1.0-ldflags-parallel-make.patch b/sys-block/btrace/files/btrace-1.1.0-ldflags-parallel-make.patch
new file mode 100644
index 000000000000..f26799238feb
--- /dev/null
+++ b/sys-block/btrace/files/btrace-1.1.0-ldflags-parallel-make.patch
@@ -0,0 +1,105 @@
+--- blktrace-1.1.0/btreplay/Makefile
++++ blktrace-1.1.0/btreplay/Makefile
+@@ -32,10 +32,10 @@
+ $(CC) $(CFLAGS) -c -o $*.o $<
+
+ btrecord: btrecord.o
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ btreplay: btreplay.o
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ depend:
+ @$(CC) -MM $(CFLAGS) *.c 1> .depend
+--- blktrace-1.1.0/btt/Makefile
++++ blktrace-1.1.0/btt/Makefile
+@@ -38,7 +38,7 @@
+ $(CC) $(CFLAGS) -c -o $*.o $<
+
+ btt: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ ifneq ($(wildcard .depend),)
+ include .depend
+--- blktrace-1.1.0/iowatcher/Makefile
++++ blktrace-1.1.0/iowatcher/Makefile
+@@ -19,7 +19,7 @@
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ iowatcher: blkparse.o plot.o main.o tracers.o mpstat.o fio.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) -lm
+
+ depend:
+ @$(CC) -MM $(ALL_CFLAGS) *.c 1> .depend
+--- blktrace-1.1.0/Makefile
++++ blktrace-1.1.0/Makefile
+@@ -4,41 +4,35 @@
+ PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
+ LIBS = -lpthread
+ SCRIPTS = btrace
++SUBDIRS = btreplay btt iowatcher
+
+-ALL = $(PROGS) $(SCRIPTS) btt/btt btreplay/btrecord btreplay/btreplay \
++ALL = $(PROGS) $(SCRIPTS)
++INSTALL_ALL = $(ALL) btt/btt btreplay/btrecord btreplay/btreplay \
+ btt/bno_plot.py iowatcher/iowatcher
+
+-all: $(ALL)
++all: $(ALL) $(SUBDIRS)
++.PHONY: $(SUBDIRS)
+
+-btt/btt:
+- $(MAKE) -C btt
+-
+-iowatcher/iowatcher:
+- $(MAKE) -C iowatcher
+-
+-btreplay/btrecord:
+- $(MAKE) -C btreplay
+-
+-btreplay/btreplay:
+- $(MAKE) -C btreplay
++$(SUBDIRS): $(PROGS)
++ $(MAKE) -C $@
+
+ %.o: %.c
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ blkparse: blkparse.o blkparse_fmt.o rbtree.o act_mask.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blktrace: blktrace.o act_mask.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ verify_blkparse: verify_blkparse.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blkrawverify: blkrawverify.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blkiomon: blkiomon.o rbtree.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
+
+ $(PROGS): | depend
+
+@@ -84,9 +78,10 @@
+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man8
+- $(INSTALL) -m 755 $(ALL) $(DESTDIR)$(bindir)
++ $(INSTALL) -m 755 $(INSTALL_ALL) $(DESTDIR)$(bindir)
+ $(INSTALL) -m 644 doc/*.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 644 doc/*.8 $(DESTDIR)$(mandir)/man8
++ $(INSTALL) -m 644 iowatcher/*.1 $(DESTDIR)$(mandir)/man1
+
+ ifneq ($(wildcard .depend),)
+ include .depend
diff --git a/sys-block/btrace/metadata.xml b/sys-block/btrace/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/sys-block/btrace/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>