summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-25 18:37:29 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-25 18:37:29 +0100
commit8a50aecb570f1c7a22f9b0d1fda5ce6a24f2e562 (patch)
tree1f462820a19e29a37a9aaf0126bfdc97e2e6ce57 /sys-block/cec
parentx11-misc/spacefm: port to EAPI 7 (diff)
downloadgentoo-8a50aecb570f1c7a22f9b0d1fda5ce6a24f2e562.tar.gz
gentoo-8a50aecb570f1c7a22f9b0d1fda5ce6a24f2e562.tar.bz2
gentoo-8a50aecb570f1c7a22f9b0d1fda5ce6a24f2e562.zip
sys-block/cec: port to EAPI 7
Closes: https://github.com/gentoo/gentoo/pull/18376 Closes: https://bugs.gentoo.org/706974 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-block/cec')
-rw-r--r--sys-block/cec/cec-14.ebuild7
-rw-r--r--sys-block/cec/files/cec-14-fno-common.patch57
2 files changed, 61 insertions, 3 deletions
diff --git a/sys-block/cec/cec-14.ebuild b/sys-block/cec/cec-14.ebuild
index 1b70ba738da6..367dcfda642f 100644
--- a/sys-block/cec/cec-14.ebuild
+++ b/sys-block/cec/cec-14.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -12,7 +12,8 @@ SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
diff --git a/sys-block/cec/files/cec-14-fno-common.patch b/sys-block/cec/files/cec-14-fno-common.patch
new file mode 100644
index 000000000000..e7e3ce022675
--- /dev/null
+++ b/sys-block/cec/files/cec-14-fno-common.patch
@@ -0,0 +1,57 @@
+--- a/cec.c
++++ b/cec.c
+@@ -20,6 +20,9 @@
+ typedef struct Shelf Shelf;
+ typedef struct Pkt Pkt;
+
++int debug;
++char *progname;
++
+ struct Pkt {
+ uchar dst[6];
+ uchar src[6];
+@@ -76,7 +79,7 @@ extern int errno;
+ Shelf tab[Ntab];
+ int ntab;
+ uchar contag;
+-extern int fd; /* set in netopen */
++int fd; /* set in netopen */
+ int shelf;
+ Shelf *connp;
+ char esc = '';
+--- a/cec.h
++++ b/cec.h
+@@ -6,8 +6,8 @@ typedef unsigned char uchar;
+ typedef unsigned int uint;
+ #endif
+
+-int debug;
+-char *progname;
++extern int debug;
++extern char *progname;
+ extern char hbacecfile[];
+
+ int netopen(char *name);
+--- a/hba.c
++++ b/hba.c
+@@ -9,7 +9,7 @@
+
+ #include "cec.h"
+
+-int fd;
++extern int fd;
+ static char hba_bytes[1<<14];
+ static int hba_len;
+
+--- a/linux.c
++++ b/linux.c
+@@ -25,7 +25,8 @@
+
+ #include "cec.h"
+
+-int fd;
++extern int fd;
++extern int debug;
+ char net_bytes[1<<14];
+ int net_len;
+ char srcaddr[6];