summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-20 13:02:21 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-20 13:02:27 -0400
commitf5ab535e7e6329f24ecb4c8395fcd642e15aca2b (patch)
treef96c8c3e0b5b222d4c22b045f0779c6f23498515 /sys-block/fio
parentsys-block/fio: version bump to 2.8 (diff)
downloadgentoo-f5ab535e7e6329f24ecb4c8395fcd642e15aca2b.tar.gz
gentoo-f5ab535e7e6329f24ecb4c8395fcd642e15aca2b.tar.bz2
gentoo-f5ab535e7e6329f24ecb4c8395fcd642e15aca2b.zip
sys-block/fio: fix build w/newer glibc #580592
Diffstat (limited to 'sys-block/fio')
-rw-r--r--sys-block/fio/files/fio-2.8-sysmacros.patch47
-rw-r--r--sys-block/fio/fio-2.6.ebuild1
-rw-r--r--sys-block/fio/fio-2.8.ebuild1
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-block/fio/files/fio-2.8-sysmacros.patch b/sys-block/fio/files/fio-2.8-sysmacros.patch
new file mode 100644
index 000000000000..0881c1b91d84
--- /dev/null
+++ b/sys-block/fio/files/fio-2.8-sysmacros.patch
@@ -0,0 +1,47 @@
+https://bugs.gentoo.org/580592
+
+From a254805d9ca1872adced3f8be2a053211b8f27eb Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 20 Apr 2016 12:51:23 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor
+
+These functions have always been defined in sys/sysmacros.h under
+Linux C libraries. For some, including sys/types.h implicitly
+includes that as well, but glibc wants to deprecate that, and some
+others already have. Include the header explicitly for the funcs.
+
+The mtd change is already in upstream mtd-utils too.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ os/os-linux.h | 1 +
+ oslib/libmtd_common.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/os/os-linux.h b/os/os-linux.h
+index 9e708f0..23c16b6 100644
+--- a/os/os-linux.h
++++ b/os/os-linux.h
+@@ -6,6 +6,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/uio.h>
+ #include <sys/syscall.h>
++#include <sys/sysmacros.h>
+ #include <sys/vfs.h>
+ #include <sys/mman.h>
+ #include <unistd.h>
+diff --git a/oslib/libmtd_common.h b/oslib/libmtd_common.h
+index a123323..9768066 100644
+--- a/oslib/libmtd_common.h
++++ b/oslib/libmtd_common.h
+@@ -30,6 +30,7 @@
+ #include <errno.h>
+ #include <features.h>
+ #include <inttypes.h>
++#include <sys/sysmacros.h>
+
+ #ifndef PROGRAM_NAME
+ # error "You must define PROGRAM_NAME before including this header"
+--
+2.7.4
+
diff --git a/sys-block/fio/fio-2.6.ebuild b/sys-block/fio/fio-2.6.ebuild
index f7a5277013f7..e66d13cada0a 100644
--- a/sys-block/fio/fio-2.6.ebuild
+++ b/sys-block/fio/fio-2.6.ebuild
@@ -38,6 +38,7 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}"/fio-2.8-sysmacros.patch #580592
epatch "${FILESDIR}"/fio-2.2.13-libmtd.patch
sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
epatch_user
diff --git a/sys-block/fio/fio-2.8.ebuild b/sys-block/fio/fio-2.8.ebuild
index cc55989c6aab..cff874b73f0d 100644
--- a/sys-block/fio/fio-2.8.ebuild
+++ b/sys-block/fio/fio-2.8.ebuild
@@ -39,6 +39,7 @@ RDEPEND+="
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}"/fio-2.8-sysmacros.patch #580592
epatch "${FILESDIR}"/fio-2.2.13-libmtd.patch
sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
epatch_user