summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/megamgr/megamgr-5.20-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/megamgr/megamgr-5.20-r2.ebuild')
-rw-r--r--sys-block/megamgr/megamgr-5.20-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-block/megamgr/megamgr-5.20-r2.ebuild b/sys-block/megamgr/megamgr-5.20-r2.ebuild
new file mode 100644
index 000000000000..450974bade25
--- /dev/null
+++ b/sys-block/megamgr/megamgr-5.20-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit multilib
+
+DESCRIPTION="LSI Logic MegaRAID Text User Interface management tool"
+HOMEPAGE="http://www.lsi.com"
+SRC_URI="http://www.lsi.com/downloads/Public/MegaRAID%20Common%20Files/ut_linux_${PN##mega}_${PV}.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+RESTRICT="mirror fetch"
+
+S="${WORKDIR}"
+
+QA_PRESTRIPPED="/opt/bin/megamgr"
+
+pkg_nofetch() {
+ einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
+ einfo "Please visit $SRC_URI"
+ einfo "And place $A in ${DISTDIR}"
+}
+
+pkg_setup() {
+ use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
+}
+
+src_install() {
+ newdoc ut_linux_${PN##mega}_${PV}.txt ${PN}-release-${PV}.txt
+
+ exeinto /opt/bin
+ newexe megamgr.bin megamgr || die
+}