summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-18 14:43:44 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-18 14:43:56 +0100
commit24244e9b7fc9f79926267b4a8a9be0565d62f6d0 (patch)
treeed8a0f6b21cec98ef3e8fb07ce2a462cddacbc4f /sys-block/nbd/nbd-3.12.1.ebuild
parentdev-java/dict4j: Stable for amd64. Stable for x86 using the ALLARCHES policy. (diff)
downloadgentoo-24244e9b7fc9f79926267b4a8a9be0565d62f6d0.tar.gz
gentoo-24244e9b7fc9f79926267b4a8a9be0565d62f6d0.tar.bz2
gentoo-24244e9b7fc9f79926267b4a8a9be0565d62f6d0.zip
sys-block/nbd: Bump to version 3.12.1
Package-Manager: portage-2.2.25 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block/nbd/nbd-3.12.1.ebuild')
-rw-r--r--sys-block/nbd/nbd-3.12.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-3.12.1.ebuild b/sys-block/nbd/nbd-3.12.1.ebuild
new file mode 100644
index 000000000000..566cdcf1596b
--- /dev/null
+++ b/sys-block/nbd/nbd-3.12.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug zlib"
+
+RDEPEND=">=dev-libs/glib-2.0
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-lfs \
+ --enable-syslog \
+ $(use_enable debug) \
+ $(use_enable zlib gznbd)
+}