summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-21 18:40:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-21 18:42:25 +0100
commit1e9e2ee79e046188ea7fd5e03499f8e37ed64972 (patch)
treed00145a02a49f9c8bf53247022bb1f6454d593cc /sys-block/open-iscsi/files
parentprofiles/arch/amd64-fbsd: Mask media-libs/xine-lib/[fusionsound] (diff)
downloadgentoo-1e9e2ee79e046188ea7fd5e03499f8e37ed64972.tar.gz
gentoo-1e9e2ee79e046188ea7fd5e03499f8e37ed64972.tar.bz2
gentoo-1e9e2ee79e046188ea7fd5e03499f8e37ed64972.zip
sys-block/open-iscsi: Bump to v2.0.876
Closes: https://bugs.gentoo.org/645910 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-block/open-iscsi/files')
-rw-r--r--sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch61
-rw-r--r--sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch92
2 files changed, 153 insertions, 0 deletions
diff --git a/sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch b/sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch
new file mode 100644
index 000000000000..2cfa43622853
--- /dev/null
+++ b/sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch
@@ -0,0 +1,61 @@
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -69,9 +69,9 @@ iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
+ iscsistart.o statics.o
+ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ -lrt $(ISCSI_LIB)
+ clean:
+- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
++ $(RM) *.o $(PROGRAMS) .depend $(LIBSYS)
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -10,9 +10,9 @@ iscsi-iname: md5.o iscsi-iname.o
+ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(DBM_LIB) -o $@
+
+ clean:
+- rm -f *.o $(PROGRAMS) .depend
++ $(RM) *.o $(PROGRAMS) .depend
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/fwparam_ibft/Makefile
++++ b/utils/fwparam_ibft/Makefile
+@@ -41,11 +41,11 @@ LDFLAGS += -L$(TOPDIR)/libopeniscsiusr -liscsiusr
+ all: $(OBJS)
+
+ clean:
+- rm -f *.o $(CLEANFILES) .depend
++ $(RM) *.o $(CLEANFILES) .depend
+
+ $(OBJS): prom_parse.tab.h prom_parse.h fwparam_ibft.h
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/sysdeps/Makefile
++++ b/utils/sysdeps/Makefile
+@@ -8,9 +8,9 @@ SYSDEPS_OBJS=sysdeps.o
+ all: $(SYSDEPS_OBJS)
+
+ clean:
+- rm -f *.o .depend
++ $(RM) *.o .depend
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--
+2.16.2
+
diff --git a/sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch b/sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch
new file mode 100644
index 000000000000..7bb0c5d6e779
--- /dev/null
+++ b/sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch
@@ -0,0 +1,92 @@
+--- a/usr/idbm.c
++++ b/usr/idbm.c
+@@ -27,2 +27,3 @@
+ #include <errno.h>
++#include <fcntl.h>
+ #include <dirent.h>
+--- a/usr/iscsiadm.c
++++ b/usr/iscsiadm.c
+@@ -3269,2 +3269,3 @@
+ int do_discover = 0, sub_mode = -1;
++ int argerror = 0;
+ int portal_type = -1;
+@@ -3458,2 +3459,5 @@
+ usage(0);
++ case '?':
++ log_error("unrecognized character '%c'", optopt);
++ argerror = 1;
+ }
+@@ -3473,4 +3477,3 @@
+
+- if (optopt) {
+- log_error("unrecognized character '%c'", optopt);
++ if (argerror) {
+ rc = ISCSI_ERR_INVAL;
+--- a/utils/fwparam_ibft/fwparam_ppc.c
++++ b/utils/fwparam_ibft/fwparam_ppc.c
+@@ -358,3 +358,3 @@
+ */
+- qsort(niclist, nic_count, sizeof(char *), (__compar_fn_t)nic_cmp);
++ qsort(niclist, nic_count, sizeof(char *), (int (*)(const void *, const void *))nic_cmp);
+
+--- a/iscsiuio/src/unix/libs/bnx2x.c
++++ b/iscsiuio/src/unix/libs/bnx2x.c
+@@ -44,3 +44,3 @@
+ #include <linux/sockios.h>
+-#include <linux/ethtool.h>
++#include "ethtool-compat.h"
+ #include <sys/mman.h>
+--- /dev/null
++++ b/iscsiuio/src/unix/libs/ethtool-compat.h
+@@ -0,0 +1,51 @@
++/*
++ * ethtool-compat.h: adopted from
++ # ethtool.h: Defines for Linux ethtool.
++ *
++ * Copyright (C) 1998 David S. Miller (davem@redhat.com)
++ * Copyright 2001 Jeff Garzik <jgarzik@pobox.com>
++ * Portions Copyright 2001 Sun Microsystems (thockin@sun.com)
++ * Portions Copyright 2002 Intel (eli.kupermann@intel.com,
++ * christopher.leech@intel.com,
++ * scott.feldman@intel.com)
++ * Portions Copyright (C) Sun Microsystems 2008
++ */
++
++#include <linux/types.h>
++#include <netinet/if_ether.h>
++
++#define ETHTOOL_FWVERS_LEN 32
++#define ETHTOOL_BUSINFO_LEN 32
++#define ETHTOOL_EROMVERS_LEN 32
++
++struct ethtool_drvinfo {
++ __u32 cmd;
++ char driver[32];
++ char version[32];
++ char fw_version[ETHTOOL_FWVERS_LEN];
++ char bus_info[ETHTOOL_BUSINFO_LEN];
++ char erom_version[ETHTOOL_EROMVERS_LEN];
++ char reserved2[12];
++ __u32 n_priv_flags;
++ __u32 n_stats;
++ __u32 testinfo_len;
++ __u32 eedump_len;
++ __u32 regdump_len;
++};
++
++struct ethtool_tcpip4_spec {
++ __be32 ip4src;
++ __be32 ip4dst;
++ __be16 psrc;
++ __be16 pdst;
++ __u8 tos;
++};
++
++struct ethtool_ah_espip4_spec {
++ __be32 ip4src;
++ __be32 ip4dst;
++ __be32 spi;
++ __u8 tos;
++};
++
++#define ETHTOOL_GDRVINFO 0x00000003 /* Get driver info. */